Hi,

today I tried to upgrade from 3.6.4 to 3.6.5, as usual with
engine-setup. This time it gives me an schema update error and after
this the database is corrupt and gives me the same error you get.

Did you create a bug entry?
I'm tired of creating bugs for oVirt. Every time I touch oVirt I hit 1-5
bugs, it's so time consuming :-(

cheers
gregor

On 22/10/15 14:24, Yaniv Dary wrote:
> History database has a issue. Can you add logs? maybe open a bug?
> 
> Yaniv Dary Technical Product Manager Red Hat Israel Ltd. 34 Jerusalem
> Road Building A, 4th floor Ra'anana, Israel 4350109 Tel : +972 (9)
> 7692306 8272306 Email: yd...@redhat.com <mailto:yd...@redhat.com> IRC :
> ydary
> 
> 
> On Tue, Sep 29, 2015 at 4:45 PM, Jon Archer <j...@rosslug.org.uk
> <mailto:j...@rosslug.org.uk>> wrote:
> 
>     Hi all,
> 
>     Wonder if anyone can shed any light on an error i'm seeing while
>     running engine-setup.
> 
>     If just upgraded the packages to the latest 3.6 ones today (from
>     3.5), run engine-setup, answered the questions, confirming install
>     then get presented with:
>     [ INFO  ] Cleaning async tasks and compensations
>     [ INFO  ] Unlocking existing entities
>     [ INFO  ] Checking the Engine database consistency
>     [ INFO  ] Stage: Transaction setup
>     [ INFO  ] Stopping engine service
>     [ INFO  ] Stopping ovirt-fence-kdump-listener service
>     [ INFO  ] Stopping websocket-proxy service
>     [ INFO  ] Stage: Misc configuration
>     [ INFO  ] Stage: Package installation
>     [ INFO  ] Stage: Misc configuration
>     [ ERROR ] Failed to execute stage 'Misc configuration': function
>     getdwhhistorytimekeepingbyvarname(unknown) does not exist LINE 2:   
>              select * from GetDwhHistoryTimekeepingByVarName(           
>                            ^ HINT:  No function matches the given name
>     and argument types. You might need to add explicit type casts.
>     [ INFO  ] Yum Performing yum transaction rollback
>     [ INFO  ] Stage: Clean up
>               Log file is located at
>     /var/log/ovirt-engine/setup/ovirt-engine-setup-20150929144137-7u5rhg.log
>     [ INFO  ] Generating answer file
>     '/var/lib/ovirt-engine/setup/answers/20150929144215-setup.conf'
>     [ INFO  ] Stage: Pre-termination
>     [ INFO  ] Stage: Termination
>     [ ERROR ] Execution of setup failed
> 
> 
>     Any ideas, where to look to fix things?
> 
>     Thanks
> 
>     Jon
>     _______________________________________________
>     Users mailing list
>     Users@ovirt.org <mailto:Users@ovirt.org>
>     http://lists.ovirt.org/mailman/listinfo/users
> 
> 
> 
> 
> _______________________________________________
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
> 
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to