On Thu, Apr 28, 2016 at 11:06 PM, Beckman, Daniel <
daniel.beck...@ingramcontent.com> wrote:

> Hello,
>
>
>
> I’m trying to setup oVirt for the first time using hosted engine. This is
> on a Dell PowerEdge R720 (512GB RAM), with 2 10G interfaces (connected to
> regular access ports on the switch, DHCP), and using external iSCSI
> storage. This is on CentOS 7.2 (latest) with the 4.5 kernel from EPEL.
> Here’s the main error I’m getting at the end of setup:
>
>
>
> RuntimeError: Failed to setup networks {'ovirtmgmt': {'nic': 'p1p1',
> 'bootproto': 'dhcp', 'blockingdhcp': True, 'defaultRoute': True}}. Error
> code: "29" message: "Determining IP information for ovirtmgmt... failed; no
> link present.  Check cable?"
>


This message comes from vdsm, can you please attach vdsm log?




>
>
> Here is what that interface ‘p1p1’ looks like:
>
>
>
> [root@labvmhostt01 ovirt-hosted-engine-setup]# cat
> /etc/sysconfig/network-scripts/ifcfg-p1p1
>
> # Generated by dracut initrd
>
> DEVICE="p1p1"
>
> ONBOOT=yes
>
> UUID="9d2666a5-9b72-4f9e-b4e9-4bfb6ad9b263"
>
> IPV6INIT=no
>
> BOOTPROTO=dhcp
>
> DEFROUTE=yes
>
> HWADDR="a0:36:9f:33:39:e8"
>
> TYPE=Ethernet
>
> NAME="p1p1"
>
> PERSISTENT_DHCLIENT=1
>
> NM_CONTROLLED=no
>
> LINKDELAY=10
>
>
>
> Note that I had added ‘linkdelay=10’ because that interface takes a while
> to come up. Without it, an ‘ifup p1p1’ will generate that same error about
> “no link present. Check cable?”. It works after a second ‘ifup p1p1’. With
> the linkdelay option it works right away. I wonder if that’s related.  From
> /var/log/messages:
>
>
>
> Apr 28 15:24:51 localhost dhclient[5976]: dhclient.c:2680: Failed to bind
> fallback interface to ovirtmgmt: No such device
>
> Apr 28 15:25:01 localhost dhclient[5976]: DHCPREQUEST on ovirtmgmt to
> 10.50.3.2 port 67 (xid=0x6d98d072)
>
> Apr 28 15:25:01 localhost dhclient[5976]: dhclient.c:2680: Failed to bind
> fallback interface to ovirtmgmt: No such device
>
> Apr 28 15:25:06 localhost systemd: Started /usr/sbin/ifup ovirtmgmt.
>
> Apr 28 15:25:06 localhost systemd: Starting /usr/sbin/ifup ovirtmgmt.
>
> Apr 28 15:25:06 localhost kernel: IPv6: ADDRCONF(NETDEV_UP): ovirtmgmt:
> link is not ready
>
> Apr 28 15:25:12 localhost kernel: ovirtmgmt: port 1(p1p1) entered disabled
> state
>
> Apr 28 15:25:48 localhost journal: vdsm vds ERROR Determining IP
> information for ovirtmgmt... failed; no link present.  Check
> cable?#012Traceback (most recent call last):#012  File
> "/usr/share/vdsm/API.py", line 1648, in _rollback#012    yield
> rollbackCtx#012  File "/usr/share/vdsm/API.py", line 1500, in
> setupNetworks#012    supervdsm.getProxy().setupNetworks(networks, bondings,
> options)#012  File "/usr/share/vdsm/supervdsm.py", line 50, in
> __call__#012    return callMethod()#012  File
> "/usr/share/vdsm/supervdsm.py", line 48, in <lambda>#012    **kwargs)#012
> File "<string>", line 2, in setupNetworks#012  File
> "/usr/lib64/python2.7/multiprocessing/managers.py", line 773, in
> _callmethod#012    raise convert_to_error(kind,
> result)#012ConfigNetworkError: (29, 'Determining IP information for
> ovirtmgmt... failed; no link present.  Check cable?')
>
>
>
> I’m attaching the setup log file. The physical interface p1p1 is indeed
> stable once up. Any help would be appreciated!
>
>
>
> Thanks,
>
> Daniel
>
>
>
>
>
>
>
>
>
>
>
>
>
> _______________________________________________
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>


-- 
Sandro Bonazzola
Better technology. Faster innovation. Powered by community collaboration.
See how it works at redhat.com
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to