Hello,
I attach to this thread to detail how I was able to have serial console
working both on CentOS 6.7 and CentOS 7.2 VMs on 3.6.5

- CentOS 6.7
Basically what described in general here (but using ttyS0 instead ttyS1):
http://www.cyberciti.biz/faq/centos-rhel-6-install-serial-console/

So in /boot/grub/grub.conf

a) right before the "hiddenmenu" line:

serial --unit=*0 *--speed=19200 --word=8 --parity=no --stop=1
terminal --timeout=5 serial console

b) At the end of kernel line added:
console=tty0 console=ttyS*0*,19200n8

Added at the end of /etc/securetty the line
ttyS0

Only difference is that as I used ttyS0, the upstart configuration was not
needed: the system after reboot was already listening on ttyS0
Creating upstart config file generated 2 processes listening on ttyS0


- CentOS 7.2
created VM with virtio console enabled in options and basically following
what described here
https://www.youtube.com/watch?v=Sx2HRwFqG7o

from default configuration I got after install:

Add in /etc/default/grub "console=ttyS0" in GRUB_CMDLINE_LINUX so that it
is now:
GRUB_CMDLINE_LINUX="rd.lvm.lv=centos/root rd.lvm.lv=centos/swap rhgb quiet
console=ttyS0"

grub2-mkconfig -o /boot/grub2/grub.cfg

reboot the VM

>From a client:
$ ssh -t -p 2222 ovirt-vmcons...@ovirt.lutwyn.org connect
Available Serial Consoles:
00 c6desktop[68a82ada-a1d2-44d0-85b0-f3a08cc2f579]
01 c7desktop[787f46f6-de4a-4b42-ba39-9609908c2905]
SELECT> 01

CentOS Linux 7 (Core)
Kernel 3.10.0-327.13.1.el7.x86_64 on an x86_64

Host-006 login: root
Password:
Last login: Tue May  3 01:34:57 on pts/0
[root@Host-006 ~]#
[root@Host-006 ~]#
[root@Host-006 ~]# cat /etc/redhat-release
CentOS Linux release 7.2.1511 (Core)
[root@Host-006 ~]# exit

HIH,
Gianluca
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to