Hi Folks,

I hate to reply to my own message, but I'm really hoping someone can help me 
with my issue
http://lists.ovirt.org/pipermail/users/2016-May/039690.html 
<http://lists.ovirt.org/pipermail/users/2016-May/039690.html>

Does anyone have a suggestion for me? If there is any more information that I 
can provide that would help you to help me, please advise.

Cheers,
Gervais



> On May 9, 2016, at 1:42 PM, Gervais de Montbrun <gerv...@demontbrun.com 
> <mailto:gerv...@demontbrun.com>> wrote:
> 
> Hi All,
> 
> I'm trying to add a third host into my oVirt cluster. I have hosted engine 
> setup on the first two. It's failing to finish the hosted-engine --deploy on 
> this third host. I wiped the server and did a CentOS 7 minimum install and 
> ran it again to have a clean machine.
> 
> My setup:
> CentOS 7 clean install
> yum install -y http://resources.ovirt.org/pub/yum-repo/ovirt-release36.rpm 
> <http://resources.ovirt.org/pub/yum-repo/ovirt-release36.rpm>
> yum install -y ovirt-hosted-engine-setup
> yum upgrade -y && reboot
> systemctl disable NetworkManager ; systemctl stop NetworkManager ; systemctl 
> disable firewalld ; systemctl stop firewalld
> hosted-engine --deploy
> 
> hosted-engine --deploy always throws an error:
> [ ERROR ] The VDSM host was found in a failed state. Please check engine and 
> bootstrap installation logs.
> [ ERROR ] Unable to add Cultivar2 to the manager
> and then echo's
> [ INFO  ] Waiting for VDSM hardware info
> ...
> [ ERROR ] Failed to execute stage 'Closing up': VDSM did not start within 120 
> seconds
> [ INFO  ] Stage: Clean up
> [ INFO  ] Generating answer file 
> '/var/lib/ovirt-hosted-engine-setup/answers/answers-20160509131103.conf'
> [ INFO  ] Stage: Pre-termination
> [ INFO  ] Stage: Termination
> [ ERROR ] Hosted Engine deployment failed: this system is not reliable, 
> please check the issue, fix and redeploy
>          Log file is located at 
> /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20160509130658-qb8ev0.log
> 
> Full output of hosted-engine --deploy included in the attached zip file.
> I've also included vdsm.log (There is more than one tries worth of tries in 
> there).
> You'll also find the ovirt-hosted-engine-setup-20160509130658-qb8ev0.log 
> listed above.
> 
> This is my "test" setup. Cultivar0 is my first host and my nfs server for 
> storage. I have two hosts in the setup already and everything is working 
> fine. The host does show up in the oVirt admin, but shows "Installed Failed"
> <PastedGraphic-1.png>
> 
> Trying to reinstall from within the interface just fails again.
> 
> The ovirt bridge interface is not configured and there are no config files in 
> /etc/sysconfi/network-scripts related to ovirt.
> 
> OS:
> [root@cultivar2 ovirt-hosted-engine-setup]# cat /etc/redhat-release 
> CentOS Linux release 7.2.1511 (Core) 
> 
> [root@cultivar2 ovirt-hosted-engine-setup]# uname -a
> Linux cultivar2.grove.silverorange.com 
> <http://cultivar2.grove.silverorange.com/> 3.10.0-327.13.1.el7.x86_64 #1 SMP 
> Thu Mar 31 16:04:38 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
> 
> Versions:
> [root@cultivar2 ovirt-hosted-engine-setup]# rpm -qa | grep -i ovirt
> libgovirt-0.3.3-1.el7_2.1.x86_64
> ovirt-hosted-engine-setup-1.3.5.0-1.1.el7.noarch
> ovirt-host-deploy-1.4.1-1.el7.centos.noarch
> ovirt-vmconsole-1.0.0-1.el7.centos.noarch
> ovirt-vmconsole-host-1.0.0-1.el7.centos.noarch
> ovirt-release36-007-1.noarch
> ovirt-engine-sdk-python-3.6.5.0-1.el7.centos.noarch
> ovirt-setup-lib-1.0.1-1.el7.centos.noarch
> ovirt-hosted-engine-ha-1.3.5.3-1.1.el7.noarch
> [root@cultivar2 ovirt-hosted-engine-setup]# 
> [root@cultivar2 ovirt-hosted-engine-setup]# 
> [root@cultivar2 ovirt-hosted-engine-setup]# 
> [root@cultivar2 ovirt-hosted-engine-setup]# rpm -qa | grep -i virt
> libvirt-daemon-driver-secret-1.2.17-13.el7_2.4.x86_64
> virt-viewer-2.0-6.el7.x86_64
> libgovirt-0.3.3-1.el7_2.1.x86_64
> libvirt-daemon-kvm-1.2.17-13.el7_2.4.x86_64
> ovirt-hosted-engine-setup-1.3.5.0-1.1.el7.noarch
> fence-virt-0.3.2-2.el7.x86_64
> virt-what-1.13-6.el7.x86_64
> libvirt-python-1.2.17-2.el7.x86_64
> libvirt-daemon-1.2.17-13.el7_2.4.x86_64
> libvirt-daemon-config-nwfilter-1.2.17-13.el7_2.4.x86_64
> libvirt-lock-sanlock-1.2.17-13.el7_2.4.x86_64
> libvirt-daemon-driver-nodedev-1.2.17-13.el7_2.4.x86_64
> libvirt-daemon-driver-network-1.2.17-13.el7_2.4.x86_64
> libvirt-daemon-driver-storage-1.2.17-13.el7_2.4.x86_64
> ovirt-host-deploy-1.4.1-1.el7.centos.noarch
> virt-v2v-1.28.1-1.55.el7.centos.2.x86_64
> ovirt-vmconsole-1.0.0-1.el7.centos.noarch
> ovirt-vmconsole-host-1.0.0-1.el7.centos.noarch
> libvirt-client-1.2.17-13.el7_2.4.x86_64
> libvirt-daemon-driver-nwfilter-1.2.17-13.el7_2.4.x86_64
> ovirt-release36-007-1.noarch
> libvirt-daemon-driver-interface-1.2.17-13.el7_2.4.x86_64
> libvirt-daemon-driver-qemu-1.2.17-13.el7_2.4.x86_64
> ovirt-engine-sdk-python-3.6.5.0-1.el7.centos.noarch
> ovirt-setup-lib-1.0.1-1.el7.centos.noarch
> ovirt-hosted-engine-ha-1.3.5.3-1.1.el7.noarch
> 
> I also have a series of stuck tasks that I can't clear related to the host 
> that can't be added... This is a secondary issue and I don't want to get off 
> track, but they look like this:
> <PastedGraphic-2.png>
> 
> I'd appreciate any help that can be offered.
> 
> Cheers,
> Gervais
> 
> 
> Gervais de Montbrun 
> Systems Administrator  / silverorange Inc. 
> 
> Phone                                         +1 902 367 4532 ext. 104 
> <tel:+1 902 367 4532 ext. 104>                                   
> Mobile                                        +1 902 978 0009 <tel:+1 902 978 
> 0009>
> 
> <hosted-engine--deploy-logs.zip>

_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to