Cam,

I believe the URL must be the following:
vpx://ARDA%5ccam@nssesxi-mgmt/Systems/North%20Sutton%20Street/nssesxi/nssesxi04-mgmt?no_verify=1
or
vpx://ARDA%5ccam@nssesxi-mgmt/North%20Sutton%20Street/Systems/nssesxi/nssesxi04-mgmt?no_verify=1


On 09/06/16 20:28, "users-boun...@ovirt.org<mailto:users-boun...@ovirt.org> on 
behalf of Cam Mac" <users-boun...@ovirt.org<mailto:users-boun...@ovirt.org> on 
behalf of iuco...@gmail.com<mailto:iuco...@gmail.com>> wrote:

Hi,

I am trying to import and convert some VMWare guests from a VMWare cluster with 
vCenter version 6, to a KVM (oVirt) host. The KVM node (RHEL 7.2) has virt-v2v 
1.28.1, though I've also tried using Fedora 23 which has 1.32.4.

The details are:

vCenter server: nssesxi-mgmt
Datacenter name: North Sutton Street
esxi server which runs the VM: nssesxi-mgmt04
folder name: Systems
VM name: wvm2
cluster name: nssesxi

I tried via the 'Import' option in the oVirt GUI, and put the details above in, 
and after thinking about it for a while, it returns a 500 internal server 
error. As I'm authing against AD, I put my username as cam@ARDA. I have 
attached the log (gzipped).


I've also tried via the command line, and the result is much the same. I did 
post the below to the libvirt-users mailing list but have not had a response, 
so I thought I'd see if anyone here might know what is going on.

Unfortunately, spaces were put in the name of the datacenter, so I escape them 
with %20

So the final URI is constructed as:

vpx://<DOMAIN\user@<vcenter_server>/<folder>/<datacenter_name>/<esxi_server> 
<vm_name>

The error I get is:

# virt-v2v -v -x -ic 
vpx://ARDA%5ccam@nssesxi-mgmt/Systems/North%20Sutton%20Street/nssesxi04-mgmt?no_verify=1
 wvm2
virt-v2v: libguestfs 1.28.1 (x86_64)
[   0.0] Opening the source -i libvirt -ic 
vpx://ARDA%5ccam@nssesxi-mgmt/Systems/North%20Sutton%20Street/nssesxi04-mgmt?no_verify=1
 wvm2
input_libvirt_vcenter_https: source: scheme vpx server nssesxi-mgmt
Enter ARDA\cam's password for nssesxi-mgmt:
libvirt: ESX Driver error : internal error: Could not find compute resource 
specified in '/Systems/North Sutton Street/nssesxi04-mgmt'
virt-v2v: error: internal error: invalid argument: cannot open libvirt
connection
'vpx://ARDA%5ccam@nssesxi-mgmt/Systems/North%20Sutton%20Street/nssesxi04-mgmt?no_verify=1'

If reporting bugs, run virt-v2v with debugging enabled and include the
complete output:

  virt-v2v -v -x [...]
#


# virsh -c 
'vpx://ARDA%5ccam@nssesxi-mgmt/Systems/North%20Sutton%20Street/nssesxi04-mgmt?no_verify=1'
 list --all
Enter ARDA\cam's password for nssesxi-mgmt:
error: failed to connect to the hypervisor
error: internal error: Could not find compute resource specified in 
'/Systems/North Sutton Street/nssesxi04-mgmt'
#

I can access via http a list of VMs at the following URL:

https://nssesxi-mgmt/folder?dcPath=North%2520Sutton%2520Street&dsName=nssesxi%252dc2%252dr10%252dlun2

Below is the URI to the vm itself (once shutdown, it gets the name 'vm2_1'):

https://nssesxi-mgmt/folder/wvm2_1?dcPath=North%2520Sutton%2520Street&dsName=nssesxi%252dc1%252dr10%252dlun2

Any ideas?

Cheers,

-Cam
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to