Yes, I am running 7.2. Here are the vdsm logs when I excuted "hosted-engine 
--deploy"

Reactor thread::INFO::2016-07-04 
17:51:49,584::protocoldetector::72::ProtocolDetector.AcceptorImpl::(handle_accept)
 Accepting connection from ::1:45014
Reactor thread::DEBUG::2016-07-04 
17:51:49,589::protocoldetector::85::ProtocolDetector.Detector::(__init__) Using 
required_size=11
Reactor thread::INFO::2016-07-04 
17:51:49,589::protocoldetector::121::ProtocolDetector.Detector::(handle_read) 
Detected protocol xml from ::1:45014
Reactor thread::DEBUG::2016-07-04 
17:51:49,589::bindingxmlrpc::1275::XmlDetector::(handle_socket) xml over http 
detected from ('::1', 45014)
BindingXMLRPC::INFO::2016-07-04 
17:51:49,589::xmlrpc::73::vds.XMLRPCServer::(handle_request) Starting request 
handler for ::1:45014
Thread-32::INFO::2016-07-04 
17:51:49,590::xmlrpc::83::vds.XMLRPCServer::(_process_requests) Request handler 
for ::1:45014 started
Thread-32::INFO::2016-07-04 
17:51:49,591::xmlrpc::91::vds.XMLRPCServer::(_process_requests) Request handler 
for ::1:45014 stopped
Reactor thread::INFO::2016-07-04 
17:52:04,607::protocoldetector::72::ProtocolDetector.AcceptorImpl::(handle_accept)
 Accepting connection from ::1:45016
Reactor thread::DEBUG::2016-07-04 
17:52:04,611::protocoldetector::85::ProtocolDetector.Detector::(__init__) Using 
required_size=11
Reactor thread::INFO::2016-07-04 
17:52:04,611::protocoldetector::121::ProtocolDetector.Detector::(handle_read) 
Detected protocol xml from ::1:45016
Reactor thread::DEBUG::2016-07-04 
17:52:04,611::bindingxmlrpc::1275::XmlDetector::(handle_socket) xml over http 
detected from ('::1', 45016)
BindingXMLRPC::INFO::2016-07-04 
17:52:04,612::xmlrpc::73::vds.XMLRPCServer::(handle_request) Starting request 
handler for ::1:45016
Thread-33::INFO::2016-07-04 
17:52:04,612::xmlrpc::83::vds.XMLRPCServer::(_process_requests) Request handler 
for ::1:45016 started
Thread-33::INFO::2016-07-04 
17:52:04,613::xmlrpc::91::vds.XMLRPCServer::(_process_requests) Request handler 
for ::1:45016 stopped
Reactor thread::INFO::2016-07-04 
17:52:19,616::protocoldetector::72::ProtocolDetector.AcceptorImpl::(handle_accept)
 Accepting connection from ::1:45018
Reactor thread::DEBUG::2016-07-04 
17:52:19,620::protocoldetector::85::ProtocolDetector.Detector::(__init__) Using 
required_size=11
Reactor thread::INFO::2016-07-04 
17:52:19,621::protocoldetector::121::ProtocolDetector.Detector::(handle_read) 
Detected protocol xml from ::1:45018
Reactor thread::DEBUG::2016-07-04 
17:52:19,621::bindingxmlrpc::1275::XmlDetector::(handle_socket) xml over http 
detected from ('::1', 45018)
BindingXMLRPC::INFO::2016-07-04 
17:52:19,621::xmlrpc::73::vds.XMLRPCServer::(handle_request) Starting request 
handler for ::1:45018
Thread-34::INFO::2016-07-04 
17:52:19,621::xmlrpc::83::vds.XMLRPCServer::(_process_requests) Request handler 
for ::1:45018 started
Thread-34::INFO::2016-07-04 
17:52:19,622::xmlrpc::91::vds.XMLRPCServer::(_process_requests) Request handler 
for ::1:45018 stopped
......

It seems that a few messages come out every 15 seconds. Is vdsmd running at a 
healthy status?




 
From: Roy Golan
Date: 2016-07-04 17:36
To: qinglong.d...@horebdata.cn
CC: users
Subject: Re: [ovirt-users] ovirt 4.0 hosted engine deploy


On Mon, Jul 4, 2016 at 12:23 PM, qinglong.d...@horebdata.cn 
<qinglong.d...@horebdata.cn> wrote:
Hi, all
        I got an error when I excuted "hosted-engine --deploy" on centos 7.0

We don't support 7.0 you need Centos 7.2  

If you are running 7.2 look at /var/log/vdsm/vdsm.log to see why it isn't 
functional  
 

[root@node ~]# hosted-engine --deploy
[ INFO  ] Stage: Initializing
[ INFO  ] Generating a temporary VNC password.
[ INFO  ] Stage: Environment setup
          During customization use CTRL-D to abort.
          Continuing will configure this host for serving as hypervisor and 
create a VM where you have to install the engine afterwards.
          Are you sure you want to continue? (Yes, No)[Yes]: 
[ INFO  ] Hardware supports virtualization
          Configuration files: []
          Log file: 
/var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20160704170730-e6bm6x.log
          Version: otopi-1.5.0 (otopi-1.5.0-1.el7.centos)
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Waiting for VDSM to reply
......
[ INFO  ] Waiting for VDSM to reply
[ ERROR ] Failed to execute stage 'Environment setup': Couldnt  connect to VDSM 
within 240 seconds
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file 
'/var/lib/ovirt-hosted-engine-setup/answers/answers-20160704171138.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Hosted Engine deployment failed: this system is not reliable, please 
check the issue, fix and redeploy
          Log file is located at 
/var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20160704170730-e6bm6x.log

Anyone can help? Thanks!




_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users


_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to