Hi Richard,

Sorry for missing that TMPDIR, I was looking rather than actually reading.

I used the original ova I'd exported from VMWare, and that worked fine
(after fixing perms). The command I ran was:

virt-v2v -x -v -i ova /mnt/import-vm/wvm2.ova -o rhev -os
ovirt-engine:/mnt/export-vm -of qcow2

It returned without error and copied it to the export domain ok. It hasn't
appeared in the list of VMs as yet in the GUI. I guess it is
in the process of doing so? It did show up in the list of importable VMs
under the 'Import VM' tab under
the export domain. I tried importing it from there but it gave me:

2016-07-20 18:27:24,518 INFO
 [org.ovirt.engine.core.bll.exportimport.ImportVmCommand] (default
task-317) [27b3ad4b] Lock freed to object
'EngineLock:{exclusiveLocks='[wvm2=<VM_NAME,
ACTION_TYPE_FAILED_NAME_ALREADY_USED>,
7d40eaee-2f3f-4a4e-8254-4c2c3312ce5c=<VM,
ACTION_TYPE_FAILED_VM_IS_BEING_IMPORTED$VmName wvm2>]',
sharedLocks='[7d40eaee-2f3f-4a4e-8254-4c2c3312ce5c=<REMOTE_VM,
ACTION_TYPE_FAILED_VM_IS_BEING_IMPORTED$VmName wvm2>]'}'

So I guess it is doing the import still.

Cheers,

Campbell


On Wed, Jul 20, 2016 at 4:05 PM, Richard W.M. Jones <rjo...@redhat.com>
wrote:

> On Wed, Jul 20, 2016 at 03:40:16PM +0100, Cam Mac wrote:
> > Hi Rich,
> >
> >
> > > > >
> > > >
> > > > I can try this but I'm not quite sure how to go about it. The ovf I
> > > created
> > > > via guest-image-ovf-creator is on an NFS mount
>
> Originally you were trying to import OVAs from VMware, which is the
> only source of OVAs we actually test.  If you're trying to import from
> VMware, get VMware to create the OVAs for you using the vSphere Export
> GUI or ovftool:
>
>   http://libguestfs.org/virt-v2v.1.html#ova:-create-ova
>
> > I'm using 'virt-v2v -v -i ova wvm2.ovf -o rhev -os
> > ovirt-engine:/mnt/export-vm' (my export domain), though unfortunately it
> > fails
> >
> > Error is:
> >
> > [root@kvm-ldn-01 tmp]# virt-v2v -v -x -i ova wvm2.ovf -o rhev -os
> > ovirt-engine:/mnt/export-vm
> > virt-v2v: libguestfs 1.28.1 (x86_64)
> > [   0.0] Opening the source -i ova wvm2.ovf
> > tar -xzf 'wvm2.ovf' -C '/var/tmp/ova.dEFSqi'
> > virt-v2v: error: could not parse ovf:Name from OVF document
>
> I had a look at guest-image-ovf-creator.py anyway and the problem is
> that this script doesn't put any <VirtualSystem> section into the OVF
> document at all.  I couldn't keep my eyes open long enough while
> reading the turgid DTMF OVF standards document to find out if this
> section is required or not, but virt-v2v certainly expects it.  (That
> is just the first failure, there may be more.)
>
> Anyway, use an OVA generated by VMware.
>
> > BTW: is there a way of specifying the extraction directory? My first
> > attempt filled up /var/tmp until I found another host
> > that luckily had a big enough partition.
>
> Yes, you can set TMPDIR as mentioned in the manual.
>
> Rich.
>
> --
> Richard Jones, Virtualization Group, Red Hat
> http://people.redhat.com/~rjones
> Read my programming and virtualization blog: http://rwmj.wordpress.com
> virt-builder quickly builds VMs from scratch
> http://libguestfs.org/virt-builder.1.html
>
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to