On 29/7/2559 15:50, Simone Tiraboschi wrote:
On Fri, Jul 29, 2016 at 6:31 AM, Wee Sritippho <we...@forest.go.th> wrote:
On 28/7/2559 15:54, Simone Tiraboschi wrote:

On Thu, Jul 28, 2016 at 10:41 AM, Wee Sritippho <we...@forest.go.th> wrote:
On 21/7/2559 16:53, Simone Tiraboschi wrote:

On Thu, Jul 21, 2016 at 11:43 AM, Wee Sritippho <we...@forest.go.th>

Can I just follow
until step 3 and do everything else via GUI?
Yes, absolutely.

Hi, I upgrade a host (host02) via GUI and now its score is 0. Restarted
the services but the result is still the same. Kinda lost now. What should I
do next?

Can you please attach ovirt-ha-agent logs?

Yes, here are the logs:
Thanks Wee,
your issue is here:
The hosted-engine storage domain is already mounted on
with a path that is not supported anymore: the right path should be

Did you manually tried to avoid the issue of a single entry point for
the gluster FS volume using host01.ovirt.forest.go.th:_hosted__engine
and host02.ovirt.forest.go.th:_hosted__engine there?
This could cause a lot of confusion since the code could not detect
that the storage domain is the same and you can end with it mounted
twice into different locations and a lot of issues.
The correct solution of that issue was this one:

Now, to have it fixed on your env you have to hack a bit.
First step, you have to edit
/etc/ovirt-hosted-engine/hosted-engine.conf on all your hosted-engine
hosts to ensure that the storage field always point to the same entry
point (host01 for instance)
Then on each host you can add something like:

Then check the representation of your storage connection in the table
storage_server_connections of the engine DB and make sure that
connection refers to the entry point you used in hosted-engine.conf on
all your hosts, you have lastly to set the value of mount_options also
Weird. The configuration in all hosts are already referring to host01.

Also, in the storage_server_connections table:

engine=> SELECT * FROM storage_server_connections;
id | connection | user_name | password | iqn | port | portal | storage_type | mount_options | vfs_type
 | nfs_version | nfs_timeo | nfs_retrans
bd78d299-c8ff-4251-8aab-432ce6443ae8 | host01.ovirt.forest.go.th:/hosted_engine | | | | | 1 | 7 | | glusterfs
 |             |           |
(1 row)

Please tune also the value of network.ping-timeout for your glusterFS
volume to avoid this:


Users mailing list

Reply via email to