----- Original Message -----
> Hi,
> 
> We're running oVirt 4.0.1 and today I found out that one of our hosts
> has all its VMs in an unknown state. I actually don't know how (and
> when) did this happen, but I'd like to restore service possibly without
> turning off these machines. The host is up, the VMs are up, 'qemu'
> process exists, no errors, it's just the VMs running on it that have a
> '?' where status is defined.
> 
> Is it safe in this case to simply modify database and set those VM's
> status to 'up'? I remember having to do this a time ago when we faced
> storage issues, it didn't break anything back then. If not, is there a
> "safe" way to migrate those VMs to a different host and restart the host
> that marked them as unknown?

Hi Nicolás,

I assume that the host these VMs are running on is empty in the webadmin,
right? if that is the case then you've probably hit [1]. Changing their
status to up is not the way to go since these VMs will not be monitored.

Yes, there is no other way to resolve it other than changing the DB but
the change should be to update run_on_vds field of these VMs to the host
you know they are running on. Their status will then be updates in 15 sec.

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1354494

Arik.

> 
> Thanks.
> 
> Nicolás
> 
> _______________________________________________
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to