> On 10 Oct 2016, at 12:21, Nelson Lameiras <nelson.lamei...@lyra-network.com> 
> wrote:
> 
> hello michal,
> 
> Yes, both paths are correct and working on the source host since the VM 
> starts and works correctly on source host. Nevertheless I have checked with 
> fdisk and mount to assure that these devices are indeed reachable.
> 
> Please understand that my setup is the following:
> source host : KVM (hosting the VM to migrate)
> target host : oVirt 4.0.4 (patched)
> 
> The error "no storage vol with matching path '/dev/sdc'" is returned by the 
> target host script /usr/lib/python2.7/site-packages/vdsm/v2v.py.

> This almost seems normal since the device /dev/sdc is not mounted on target 
> host (where script is running) but only on source host.

it should “call” the source one to get the data. You should see that error on 
the source host. As far as I can see from that short log you pasted it asks for 
the right device..I’m just not sure it’s the right host - can you confirm you 
see that "no storage vol with matching path '/dev/sdc’” on the source host? 
Might need to enable libvirt debug logs to see a bit more 
(http://wiki.libvirt.org/page/DebugLogs)

Thanks,
michal

> 
> Can this be the source of the error ?
> 
> cordialement, regards, 
> Nelson LAMEIRAS 
> 
> Lyra Network 
> Service Projets et Processus 
> Tel : +33 (0) 5 32 09 09 70 
> 109 rue de l’innovation 
> 31670 Labège - France 
> www.lyra-network.com
> 
> ----- Original Message -----
> From: "Michal Skrivanek" <michal.skriva...@redhat.com>
> To: "Nelson Lameiras" <nelson.lamei...@lyra-network.com>
> Cc: "Shahar Havivi" <shav...@redhat.com>, users@ovirt.org
> Sent: Friday, October 7, 2016 3:50:44 PM
> Subject: Re: [ovirt-users] can't import vm from KVM host
> 
>> On 7 Oct 2016, at 09:42, Nelson Lameiras <nelson.lamei...@lyra-network.com> 
>> wrote:
>> 
>> hello,
>> 
>> any news on this issue ?
> 
> Hi, Shahar is out on vacation for few weeks
> 
>> can I do anything to help ?
> 
> hm...looking at the error, can you please confirm those paths 
> ('/dev/mapper/vg_00-lv_sys’, /dev/sdc) are mounted/correct on the source host?
> Seems like the patch works and adds those disks all right, but further 
> queries fails indicating those disks are not reachable.
> 
> Thanks,
> michal
> 
>> 
>> cordialement, regards, 
>> Nelson LAMEIRAS 
>> 
>> Lyra Network 
>> Service Projets et Processus 
>> Tel : +33 (0) 5 32 09 09 70 
>> 109 rue de l’innovation 
>> 31670 Labège - France 
>> www.lyra-network.com
>> 
>> ----- Original Message -----
>> From: "Shahar Havivi" <shav...@redhat.com>
>> To: "Nelson Lameiras" <nelson.lamei...@lyra-network.com>
>> Cc: users@ovirt.org
>> Sent: Thursday, September 29, 2016 2:31:42 PM
>> Subject: Re: [ovirt-users] can't import vm from KVM host
>> 
>> On 29.09.16 14:22, Nelson Lameiras wrote:
>>> Shahar,
>>> 
>>> I took the liberty to try to patch our test setup with the fix I took from 
>>> https://gerrit.ovirt.org/#/c/64272/4/ (lib/vdsm/v2v.py)
>>> I restarted vdsm afterwards
>>> 
>>> Result :
>>> In the GUI import page, now when clicking on "load" button (just before 
>>> guetting the list of vm to import on source), an error occurs : "Failed to 
>>> communicate with the external provider, see log for additional details."
>>> 
>>> Error on engine log :
>>> 
>>> "
>>> 2016-09-29 14:13:48,637 ERROR 
>>> [org.ovirt.engine.core.vdsbroker.vdsbroker.GetVmsFromExternalProviderVDSCommand]
>>>  (default task-30) [] Failed in 'GetVmsFromExternalProviderVDS' method, for 
>>> vds: 'virtintelan01.lbg.office.lyra'; host: 
>>> 'virtintelan01.lbg.office.lyra': null
>>> 2016-09-29 14:13:48,637 ERROR 
>>> [org.ovirt.engine.core.vdsbroker.vdsbroker.GetVmsFromExternalProviderVDSCommand]
>>>  (default task-30) [] Command 
>>> 'GetVmsFromExternalProviderVDSCommand(HostName = 
>>> virtintelan01.lbg.office.lyra, 
>>> GetVmsFromExternalProviderParameters:{runAsync='true', 
>>> hostId='20b59a24-0098-461a-b4a3-7d6213b96c52', 
>>> url='qemu+ssh://root@192.168.210.140/system', username='null', 
>>> originType='KVM'})' execution failed: null
>>> 2016-09-29 14:13:48,637 INFO  
>>> [org.ovirt.engine.core.vdsbroker.vdsbroker.GetVmsFromExternalProviderVDSCommand]
>>>  (default task-30) [] FINISH, GetVmsFromExternalProviderVDSCommand, log id: 
>>> 6e062276
>>> 2016-09-29 14:13:48,637 ERROR 
>>> [org.ovirt.engine.core.bll.GetVmsFromExternalProviderQuery] (default 
>>> task-30) [] Query 'GetVmsFromExternalProviderQuery' failed: 
>>> EngineException: java.lang.NumberFormatException: null (Failed with error 
>>> ENGINE and code 5001)
>>> 2016-09-29 14:13:48,637 ERROR 
>>> [org.ovirt.engine.core.bll.GetVmsFromExternalProviderQuery] (default 
>>> task-30) [] Exception: org.ovirt.engine.core.common.errors.EngineException: 
>>> EngineException: java.lang.NumberFormatException: null (Failed with error 
>>> ENGINE and code 5001)
>>>       at 
>>> org.ovirt.engine.core.bll.VdsHandler.handleVdsResult(VdsHandler.java:114) 
>>> [bll.jar:]
>>>       at 
>>> org.ovirt.engine.core.bll.VDSBrokerFrontendImpl.runVdsCommand(VDSBrokerFrontendImpl.java:33)
>>>  [bll.jar:]
>>>       at 
>>> org.ovirt.engine.core.bll.QueriesCommandBase.runVdsCommand(QueriesCommandBase.java:257)
>>>  [bll.jar:]
>>>       ...
>>> "
>>> 
>>> In the host, I can see the following errors on /var/log/messages : 
>>> 
>>> "
>>> Sep 29 14:11:39 virtintelan01 journal: vdsm root ERROR Error getting disk 
>>> size#012Traceback (most recent call last):#012  File 
>>> "/usr/lib/python2.7/site-packages/vdsm/v2v.py", line 931, in 
>>> _add_disk_info#012    vol = conn.storageVolLookupByPath(disk['alias'])#012  
>>> File "/usr/lib64/python2.7/site-packages/libvirt.py", line 4596, in 
>>> storageVolLookupByPath#012    if ret is None:raise 
>>> libvirtError('virStorageVolLookupByPath() failed', 
>>> conn=self)#012libvirtError: Volume de stockage introuvable : no storage vol 
>>> with matching path '/dev/mapper/vg_00-lv_sys'
>>> Sep 29 14:11:39 virtintelan01 journal: vdsm root ERROR Error getting disk 
>>> size#012Traceback (most recent call last):#012  File 
>>> "/usr/lib/python2.7/site-packages/vdsm/v2v.py", line 931, in 
>>> _add_disk_info#012    vol = conn.storageVolLookupByPath(disk['alias'])#012  
>>> File "/usr/lib64/python2.7/site-packages/libvirt.py", line 4596, in 
>>> storageVolLookupByPath#012    if ret is None:raise 
>>> libvirtError('virStorageVolLookupByPath() failed', 
>>> conn=self)#012libvirtError: Volume de stockage introuvable : no storage vol 
>>> with matching path '/dev/sdc'
>>> "
>>> 
>>> FYI "Volume de stockage introuvable" (french) = "storage volume not found" 
>>> 
>>> This error did not appear before patching with the fix.
>>> 
>>> I repeated the operation 2 times with a clean setup + patch. Same 
>>> behaviour. Maybe I'm doing something wrong?
>> I need to check,
>> Thanks for the info.
>> 
>>> 
>>> my setup :
>>> ovirt-engine : centos 7.2 + ovirt 4.0.4
>>> hosts : centos 7.2 + ovirt 4.0.4 + fix
>>> 
>>> cordialement, regards, 
>>> Nelson LAMEIRAS 
>>> 
>>> Lyra Network 
>>> Service Projets et Processus 
>>> Tel : +33 (0) 5 32 09 09 70 
>>> 109 rue de l’innovation 
>>> 31670 Labège - France 
>>> www.lyra-network.com
>>> 
>>> ----- Original Message -----
>>> From: "Nelson Lameiras" <nelson.lamei...@lyra-network.com>
>>> To: "Shahar Havivi" <shav...@redhat.com>
>>> Cc: users@ovirt.org
>>> Sent: Friday, September 23, 2016 11:55:08 AM
>>> Subject: Re: [ovirt-users] can't import vm from KVM host
>>> 
>>> Shahar,
>>> 
>>> Thanks!
>>> I'll keep an eye on this bug and try to be helpfull when testing the fix.
>>> 
>>> nelson
>>> 
>>> ----- Original Message -----
>>> From: "Shahar Havivi" <shav...@redhat.com>
>>> To: "Nelson Lameiras" <nelson.lamei...@lyra-network.com>
>>> Cc: "Nisim Simsolo" <nsims...@redhat.com>, users@ovirt.org
>>> Sent: Thursday, September 22, 2016 10:14:33 AM
>>> Subject: Re: [ovirt-users] can't import vm from KVM host
>>> 
>>> Nelson,
>>> I opened a bug regarding your issue
>>> https://bugzilla.redhat.com/show_bug.cgi?id=1378340
>>> 
>>> And send a fix:
>>> https://gerrit.ovirt.org/#/c/64272/
>>> 
>>> Thank you for your help!
>>> 
>>> Shahar.
>>> 
>>> On 21.09.16 10:57, Shahar Havivi wrote:
>>>> On 20.09.16 10:24, Nelson Lameiras wrote:
>>>>> Here is the disk section of my vm,
>>>>> 
>>>>> ...
>>>>>   <disk type='block' device='disk'>
>>>>>     <driver name='qemu' type='raw' cache='none' io='native'/>
>>>>>     <source dev='/dev/mapper/vg_01-lv_sys'/>
>>>>>     <target dev='vda' bus='virtio'/>
>>>>>     <address type='pci' domain='0x0000' bus='0x00' slot='0x07' 
>>>>> function='0x0'/>
>>>>>   </disk>
>>>>>   <disk type='block' device='disk'>
>>>>>     <driver name='qemu' type='raw' cache='none' io='native'/>
>>>>>     <source dev='/dev/sdc'/>
>>>>>     <target dev='vdb' bus='virtio'/>
>>>>>     <address type='pci' domain='0x0000' bus='0x00' slot='0x08' 
>>>>> function='0x0'/>
>>>>>   </disk>
>>>>> ...
>>>>> 
>>>>> nelson
>>>> Thanks Nelson,
>>>> bz 1362525 will not solve your issue.
>>>> We will start work on that block device issue shortly and I hope that it 
>>>> will
>>>> make it to the next release.
>>>> 
>>>> Thank you,
>>>> Shahar.
>>>> 
>>>>> 
>>>>> 
>>>>> ----- Original Message -----
>>>>> From: "Shahar Havivi" <shav...@redhat.com>
>>>>> To: "Nelson Lameiras" <nelson.lamei...@lyra-network.com>
>>>>> Cc: "Nisim Simsolo" <nsims...@redhat.com>, users@ovirt.org
>>>>> Sent: Tuesday, September 20, 2016 8:04:41 AM
>>>>> Subject: Re: [ovirt-users] can't import vm from KVM host
>>>>> 
>>>>> On 19.09.16 18:11, Nelson Lameiras wrote:
>>>>>> Well I think I have a rather "classical" environment :
>>>>>> 
>>>>>> This is the test setup I created (from scratch) in order to simulate 
>>>>>> future migrations (which will be used to migrate our hundreds of vm in 
>>>>>> production)
>>>>>> 
>>>>>> On one side, I have a x86_64 centos7.2+KVM hosting one VM with 2 iscsi 
>>>>>> disks : 
>>>>>> 1 LVM block device /dev/mapper/vg_01-lv_sys, using virtio
>>>>>> 1 block device /dev/sdc, using virtio
>>>>>> 
>>>>>> on the other side, I have a x86_64 centos 7.2 oVirt cluster (2 hosts, 
>>>>>> same hardware as KVM hosts) installed with 4.0.3 oVirt (hosts and 
>>>>>> engine) fully upgraded to 4.0.4RC1 (hosts and engine)
>>>>>> Target would be oVirt iscsi Data Domain disk (which is irrelevant 
>>>>>> because the problem I'm describing arises before selecting oVirt target)
>>>>>> 
>>>>>> I'm using the GUI to test the native import capabilities of oVirt 
>>>>>> "Import VM"
>>>>>> When selecting KVM import, putting correct URL data (using either tcp or 
>>>>>> ssh transport), I get a list of VM machines running in the KVM cluster 
>>>>>> (for this exemple, only the one VM described above), but the disk count 
>>>>>> is always 0. Which makes it impossible to import the VM.
>>>>>> 
>>>>>> I should add that I made the same VM import using "local hard drives" 
>>>>>> (ie. local raw file) and it works as expected, I can see one or multiple 
>>>>>> disks and import them easily to oVirt. The problem seems to manifest 
>>>>>> itself only when importing disks using block devices directly.
>>>>>> 
>>>>>> Do you need more information from me, or make more tests?
>>>>>> 
>>>>>> thanks a lot,
>>>>>> nelson
>>>>> Can you post the libvirt xml as attachment here (at least the disks 
>>>>> sections):
>>>>> 
>>>>> $ virsh -r dumpxml <vmname>
>>>>> 
>>>>> Shahar.
>>> _______________________________________________
>>> Users mailing list
>>> Users@ovirt.org
>>> http://lists.ovirt.org/mailman/listinfo/users
>> _______________________________________________
>> Users mailing list
>> Users@ovirt.org
>> http://lists.ovirt.org/mailman/listinfo/users
>> 
>> 
> _______________________________________________
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
> 
> 

_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to