(Replying to the list and Fabian as well)

On Wed, Nov 30, 2016 at 12:45 PM, Shalabh Goel <shalabhgoe...@gmail.com> wrote:
> Thanks for the reply. I looked into the logs in ovirt-engine server. The log
> is as follows:
>
> File "/usr/lib/python2.7/site-packages/yum/repos.py", line 344, in
> populateSack
>     self.doSetup()
>   File "/usr/lib/python2.7/site-packages/yum/repos.py", line 158, in doSetup
>     self.ayum.plugins.run('postreposetup')
>   File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 188, in run
>     func(conduitcls(self, self.base, conf, **kwargs))
>   File "/usr/lib/yum-plugins/fastestmirror.py", line 197, in
> postreposetup_hook
>     if downgrade_ftp and _len_non_ftp(repo.urls) == 1:
>   File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 871, in
> <lambda>
>     urls = property(fget=lambda self: self._geturls(),
>   File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 868, in
> _geturls
>     self._baseurlSetup()
>   File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 834, in
> _baseurlSetup
>     self.check()
>   File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 554, in check
>     'Cannot find a valid baseurl for repo: %s' % self.ui_id
> RepoError: Cannot find a valid baseurl for repo: ovirt-4.0/7
> 2016-11-24 11:24:24 ERROR otopi.context context._executeMethod:151 Failed to
> execute stage 'Environment packages setup': Cannot find a valid baseurl for
> repo
> : ovirt-4.0/7
> 2016-11-24 11:24:24 DEBUG otopi.transaction transaction.abort:119 aborting
> 'Yum Transaction'
> 2016-11-24 11:24:24 INFO otopi.plugins.otopi.packagers.yumpackager
> yumpackager.info:80 Yum Performing yum transaction rollback
> Could not retrieve mirrorlist
> http://resources.ovirt.org/pub/yum-repo/mirrorlist-ovirt-4.0-el7 error was
> 14: curl#7 - "Failed to connect to 66.187.230.28: Network is unreachable"
> Loaded plugins: fastestmirror
> 2016-11-24 11:24:24 DEBUG otopi.context context.dumpEnvironment:760
> ENVIRONMENT DUMP - BEGIN
> 2016-11-24 11:24:24 DEBUG otopi.context context.dumpEnvironment:770 ENV
> BASE/error=bool:'True'
> 2016-11-24 11:24:24 DEBUG otopi.context context.dumpEnvironment:770 ENV
> BASE/exceptionInfo=list:'[(<class 'yum.Errors.RepoError'>, RepoError(),
> <traceback ob
> ject at 0x2e88c20>)]'
> 2016-11-24 11:24:24 DEBUG otopi.context context.dumpEnvironment:774
> ENVIRONMENT DUMP - END
> 2016-11-24 11:24:24 INFO otopi.context context.runSequence:687 Stage:
> Pre-termination
> 2016-11-24 11:24:24 DEBUG otopi.context context.runSequence:691 STAGE
> pre-terminate
> 2016-11-24 11:24:24 DEBUG otopi.context context._executeMethod:128 Stage
> pre-terminate METHOD otopi.plugins.otopi.core.misc.Plugin._preTerminate
> 2016-11-24 11:24:24 DEBUG otopi.context context.dumpEnvironment:760
> ENVIRONMENT DUMP - BEGIN
> 2016-11-24 11:24:24 DEBUG otopi.context context.dumpEnvironment:770 ENV
> BASE/aborted=bool:'False'
> 2016-11-24 11:24:24 DEBUG otopi.context context.dumpEnvironment:770 ENV
> BASE/debug=int:'0'
> 2016-11-24 11:24:24 DEBUG otopi.context context.dumpEnvironment:770 ENV
> BASE/error=bool:'True'
> 2016-11-24 11:24:24 DEBUG otopi.context context.dumpEnvironment:770 ENV
> BASE/exceptionInfo=list:'[(<class 'yum.Errors.RepoError'>, RepoError(),
> <traceback ob
> :
>
> So my question is that if yum is the reason for the host install failing? Do
> I absolutely need Internet connectivity for the node also? What if the
> python file can be edited to prevent it? I have installed the node using the
> node ISO available on the ovirt website

Not sure about node specifically.

You can try preventing host-deploy from trying to update packages using:

https://gerrit.ovirt.org/gitweb?p=ovirt-host-deploy.git;a=blob;f=README

Search there for 'OFFLINE'.

Best,

>
> Thank You
>
> Shalabh Goel
>
> On Wed, Nov 30, 2016 at 2:03 PM, Yedidyah Bar David <d...@redhat.com> wrote:
>>
>> On Wed, Nov 30, 2016 at 9:44 AM, Shalabh Goel <shalabhgoe...@gmail.com>
>> wrote:
>> > Hi
>> >
>> > I just want to know if there is any way I can disable the yum looking
>> > for
>> > updates on the internet on the node?
>>
>> Not sure, adding Fabian.
>>
>> I think this should work if you add a proxy= line to yum.conf.
>> Not sure how to persist this in node.
>>
>> Best,
>>
>> >
>> > Please help me out here.
>> >
>> > Thanks
>> >
>> > Shalabh Goel
>> >
>> >
>> >
>> >
>> > On Tue, Nov 29, 2016 at 5:59 PM, <users-requ...@ovirt.org> wrote:
>> >>
>> >> Send Users mailing list submissions to
>> >>         users@ovirt.org
>> >>
>> >> To subscribe or unsubscribe via the World Wide Web, visit
>> >>         http://lists.ovirt.org/mailman/listinfo/users
>> >> or, via email, send a message with subject or body 'help' to
>> >>         users-requ...@ovirt.org
>> >>
>> >> You can reach the person managing the list at
>> >>         users-ow...@ovirt.org
>> >>
>> >> When replying, please edit your Subject line so it is more specific
>> >> than "Re: Contents of Users digest..."
>> >>
>> >>
>> >> Today's Topics:
>> >>
>> >>    1. Re:  I wrote an oVirt thing (Yaniv Kaul)
>> >>    2.  Ovirt node host installation failing in engine (Shalabh Goel)
>> >>    3. Re:  How to migrate Self Hosted Engine (Gianluca Cecchi)
>> >>    4. Re:  Need help with dashboard (????? ???????)
>> >>
>> >>
>> >> ----------------------------------------------------------------------
>> >>
>> >> Message: 1
>> >> Date: Tue, 29 Nov 2016 14:06:22 +0200
>> >> From: Yaniv Kaul <yk...@redhat.com>
>> >> To: Konstantin Shalygin <k0...@k0ste.ru>
>> >> Cc: Ovirt Users <users@ovirt.org>
>> >> Subject: Re: [ovirt-users] I wrote an oVirt thing
>> >> Message-ID:
>> >>
>> >> <CAJgorsY_SksEnP2jQxBgdJyKW=4_qZZGZ=dwhq13mteen5j...@mail.gmail.com>
>> >> Content-Type: text/plain; charset="utf-8"
>> >>
>> >> On Tue, Nov 29, 2016 at 3:40 AM, Konstantin Shalygin <k0...@k0ste.ru>
>> >> wrote:
>> >>
>> >> > ovirt-shell will be deprecated and not supported or some functions on
>> >> > ovirt-shell (or all package ovirt-engine-cli)?
>> >> >
>> >> > We use ovirt-shell on client desktops who connected to SPICE consoles
>> >> > and
>> >> > work (users provided by LDAP on ovirt-engine), like via RDP. For this
>> >> > I
>> >> > wrote very fast-hack patch for ovirt-shell and GUI for enter password
>> >> > (
>> >> > https://github.com/k0ste/ovirt-pygtk). Very simple, but via Internet
>> >> > people use SPICE without negative about packet loss and disconnects,
>> >> > instead RDP.
>> >>
>> >>
>> >> Can you further explain the use case? I assume the user portal is not
>> >> good
>> >> enough for some reason?
>> >>
>> >>
>> >> >
>> >> >
>> >> > BTW, the ovirt-shell is something we deprecated. It is working on top
>> >> > of
>> >> >> the v3 api, which we plan to remove in 4.2.
>> >> >> So better not use it.
>> >> >>
>> >> >
>> >> >
>> >> > You can start maintain. For example I maintain packes for Arch Linux:
>> >> > ovirt-engine-cli
>> >> > (https://aur.archlinux.org/packages/ovirt-engine-cli)
>> >> > and ovirt-engine-sdk-python (https://aur.archlinux.org/pac
>> >> > kages/ovirt-engine-sdk-python).
>> >>
>> >>
>> >> Hi,
>> >>
>> >> It somehow looks like a fork of the CLI (due to the added patch[1]).
>> >> I'm not sure how happy I am about it, considering the patch is adding a
>> >> feature with security issues (there is a reason we do not support
>> >> password
>> >> passed via the command line - it's somewhat less secure).
>> >> Since you are already checking for the CLI rc file[2], just add the
>> >> password to it and launch with it (in a temp file in the temp directory
>> >> with the right permissions, etc...)
>> >>
>> >> BTW, note that the attempt to delete the password from memory[3] may or
>> >> may
>> >> not work. After all, it's a copy of what you got from entry.get_text()
>> >> few
>> >> lines before.
>> >> And Python GC is not really to be relied upon to delete things ASAP
>> >> anyway.
>> >> There are some lovely discussions on the Internet about it. For
>> >> example[4].
>> >> Y.
>> >>
>> >> [1]
>> >>
>> >> https://github.com/k0ste/ovirt-pygtk/blob/master/add_password_option.patch
>> >> [2] https://github.com/k0ste/ovirt-pygtk/blob/master/ovirt-pygtk.py#L81
>> >> [3] https://github.com/k0ste/ovirt-pygtk/blob/master/ovirt-pygtk.py#L71
>> >> [4]
>> >>
>> >>
>> >> http://stackoverflow.com/questions/728164/securely-erasing-password-in-memory-python
>> >>
>> >> >
>> >> >
>> >> >   My workstation at work is running Ubuntu, and I do not believe that
>> >> >> ovirt-shell is packaged for it.
>> >> >>
>> >> >
>> >> > --
>> >> > Best regards,
>> >> > Konstantin Shalygin
>> >> >
>> >> >
>> >> >
>> >> > _______________________________________________
>> >> > Users mailing list
>> >> > Users@ovirt.org
>> >> > http://lists.ovirt.org/mailman/listinfo/users
>> >> >
>> >> -------------- next part --------------
>> >> An HTML attachment was scrubbed...
>> >> URL:
>> >>
>> >> <http://lists.ovirt.org/pipermail/users/attachments/20161129/4c62f1cf/attachment-0001.html>
>> >>
>> >> ------------------------------
>> >>
>> >> Message: 2
>> >> Date: Mon, 28 Nov 2016 10:00:31 +0530
>> >> From: Shalabh Goel <shalabhgoe...@gmail.com>
>> >> To: users@ovirt.org
>> >> Subject: [ovirt-users] Ovirt node host installation failing in engine
>> >> Message-ID:
>> >>
>> >> <caenn9my9qcgyqlsqav+w9pioajwqqtpvqdliytlof3sc5ti...@mail.gmail.com>
>> >> Content-Type: text/plain; charset="utf-8"
>> >>
>> >>
>> >> Hi
>> >>
>> >> I have installed ovirt engine (version 4) on Centos 7.2 in one server
>> >> system and 1 ovirt node (version 4) using ovirt node iso in another
>> >> system.
>> >> But when am adding the node in the engine from web portal, the
>> >> installation
>> >> is failing on the node. There is no Internet connectivity to the node.
>> >> When
>> >> I checked the logs, I found that it is trying to connect to a repo
>> >> using
>> >> yum. My questions are:
>> >>
>> >> 1. Is internet connectivity required on the node?
>> >>
>> >> 2. If I cannot provide internet connectivity to the node. Please
>> >> suggest a
>> >> work around.
>> >>
>> >>
>> >> Thank You
>> >>
>> >> Shalabh Goel
>> >> -------------- next part --------------
>> >> An HTML attachment was scrubbed...
>> >> URL:
>> >>
>> >> <http://lists.ovirt.org/pipermail/users/attachments/20161128/6ee65704/attachment-0001.html>
>> >>
>> >> ------------------------------
>> >>
>> >> Message: 3
>> >> Date: Tue, 29 Nov 2016 13:27:06 +0100
>> >> From: Gianluca Cecchi <gianluca.cec...@gmail.com>
>> >> To: Yedidyah Bar David <d...@redhat.com>
>> >> Cc: users <users@ovirt.org>
>> >> Subject: Re: [ovirt-users] How to migrate Self Hosted Engine
>> >> Message-ID:
>> >>
>> >> <CAG2kNCz=2Gz1CJtLLT2mtT3E+wzH0=vtugmobs_fd7e1cxi...@mail.gmail.com>
>> >> Content-Type: text/plain; charset="utf-8"
>> >>
>> >> On Mon, Nov 21, 2016 at 8:54 AM, Yedidyah Bar David <d...@redhat.com>
>> >> wrote:
>> >>
>> >> > On Mon, Nov 21, 2016 at 1:09 AM, Gianluca Cecchi
>> >> >
>> >> > >
>> >> > > Two notes:
>> >> > > 1) it would be nice to pre-filter the drop down box when you have
>> >> > > to
>> >> > choose
>> >> > > the host where migrate the hosted engine...
>> >> > > So that if there are no hosts available you will be given a related
>> >> > message
>> >> > > without choice at all and if there is a subset of eligible hosts
>> >> > > inside
>> >> > the
>> >> > > cluster, you will be proposed only to choose one of them and not
>> >> > > all
>> >> > > the
>> >> > > hosts inside the cluster.
>> >> >
>> >> > Makes sense, please open an RFE to track this. Thanks.
>> >> >
>> >>
>> >> Been busy these latest days...
>> >> Opened now:
>> >> https://bugzilla.redhat.com/show_bug.cgi?id=1399609
>> >>
>> >>
>> >> >
>> >> > >
>> >> > > 2) If the gui option becomes the default and preferred way to
>> >> > > deploy
>> >> > hosts
>> >> > > in self hosted engine environments I think it should be put in
>> >> > > clearer
>> >> > shape
>> >> > > that if you follow the default action you would not have high
>> >> > availability
>> >> > > for the hosted engine vm.
>> >> > > Or changing the default action to "Deploy", or showing a popup if
>> >> > > the
>> >> > hosted
>> >> > > engine vm has only one host configured for it but there are other
>> >> > > hosts
>> >> > in
>> >> > > the cluster.
>> >> > > Just my opinion.
>> >> >
>> >> > Makes sense too, but I wonder if people will then be annoyed by
>> >> > forgetting
>> >> > to uncheck it even after having enough HA hosts, which does have its
>> >> > cost
>> >> > (both actual resource use and also reservations, IIUC). Perhaps we
>> >> > should
>> >> > enable by default and/or remind only until you have enough HA hosts,
>> >> > which
>> >> > can be a configurable number (and default e.g. to 3).
>> >> >
>> >> >
>> >> >
>> >> and here:
>> >> https://bugzilla.redhat.com/show_bug.cgi?id=1399613
>> >>
>> >> Cheers,
>> >> Gianluca
>> >> -------------- next part --------------
>> >> An HTML attachment was scrubbed...
>> >> URL:
>> >>
>> >> <http://lists.ovirt.org/pipermail/users/attachments/20161129/3eccc506/attachment-0001.html>
>> >>
>> >> ------------------------------
>> >>
>> >> Message: 4
>> >> Date: Tue, 29 Nov 2016 12:28:55 +0000
>> >> From: ????? ??????? <mishani...@gmail.com>
>> >> To: Shirly Radco <sra...@redhat.com>
>> >> Cc: "Users@ovirt.org" <Users@ovirt.org>
>> >> Subject: Re: [ovirt-users] Need help with dashboard
>> >> Message-ID:
>> >>
>> >> <cadyan2fiqad9abujrlbx2r175x1vcggyj-aqq9whz7g8+7e...@mail.gmail.com>
>> >> Content-Type: text/plain; charset="utf-8"
>> >>
>> >> Thank you, I have created a bug.
>> >>
>> >> https://bugzilla.redhat.com/show_bug.cgi?id=1399597
>> >>
>> >>
>> >> ??, 29 ????. 2016 ?. ? 13:54, Shirly Radco <sra...@redhat.com>:
>> >>
>> >> > # su - postgres
>> >> > $ pg_dump --file ovirt_engine_history.dump ovirt_engine_history
>> >> >
>> >> > Best regards,
>> >> >
>> >> > Shirly Radco
>> >> >
>> >> > BI Software Engineer
>> >> > Red Hat Israel Ltd.
>> >> > 34 Jerusalem Road
>> >> > Building A, 4th floor
>> >> > Ra'anana, Israel 4350109
>> >> >
>> >> >
>> >> > On Mon, Nov 28, 2016 at 9:25 AM, ????? ??????? <mishani...@gmail.com>
>> >> > wrote:
>> >> >
>> >> > Hi, sorry for the delay, I do not know how to create
>> >> > "ovirt_engine_history db dump"?
>> >> >
>> >> >
>> >> > ??, 22 ????. 2016 ?. ? 10:52, Shirly Radco <sra...@redhat.com>:
>> >> >
>> >> > Hi,
>> >> >
>> >> > Can you please open a bug?
>> >> > Please attach to the bug these files+ the screenshots +
>> >> > ovirt_engine_history db dump.
>> >> >
>> >> > Thank you,
>> >> >
>> >> > Shirly Radco
>> >> >
>> >> > BI Software Engineer
>> >> > Red Hat Israel Ltd.
>> >> > 34 Jerusalem Road
>> >> > Building A, 4th floor
>> >> > Ra'anana, Israel 4350109
>> >> >
>> >> >
>> >> > On Mon, Nov 21, 2016 at 4:56 PM, ????? ??????? <mishani...@gmail.com>
>> >> > wrote:
>> >> >
>> >> > Thank you that you have answered me. I mean, the data is not
>> >> > displayed
>> >> > at the bottom of Dashboard. Log files and the status of the services
>> >> > I
>> >> > attached to the letter.
>> >> >
>> >> >
>> >> > ??, 20 ????. 2016 ?. ? 11:13, Shirly Radco <sra...@redhat.com>:
>> >> >
>> >> > Hi,
>> >> >
>> >> > You attached twice the same screenshot...
>> >> > Please attach the screenshot with the missing data.
>> >> >
>> >> > Also, the data for the graphs is collected by the ovirt-engine-dwhd
>> >> > service.
>> >> > Please see if the service is running, also check logs for errors.
>> >> > Please attach the log.
>> >> >
>> >> >
>> >> >
>> >> > Best regards,
>> >> >
>> >> > Shirly Radco
>> >> >
>> >> > BI Software Engineer
>> >> > Red Hat Israel Ltd.
>> >> > 34 Jerusalem Road
>> >> > Building A, 4th floor
>> >> > Ra'anana, Israel 4350109
>> >> >
>> >> >
>> >> > On Sun, Nov 20, 2016 at 9:31 AM, ????? ??????? <mishani...@gmail.com>
>> >> > wrote:
>> >> >
>> >> >
>> >> >
>> >> > Hi, I need help to load Dasboard, he is incorrectly displayed
>> >> > graphics
>> >> > processor is not displayed data, memory, disk volume. I installed 3
>> >> > hosts
>> >> > with glusterfs. After installation everything worked fine and the
>> >> > data
>> >> > is
>> >> > displayed correctly, but then everything was as follows. What could
>> >> > be a
>> >> > problem?
>> >> >
>> >> >
>> >> >
>> >> > oVirt Engine Version: 4.0.5.5-1.el7.centos
>> >> >
>> >> >
>> >> > [image: pasted1]
>> >> >
>> >> > [image: pasted3]
>> >> >
>> >> > [image: pasted2]
>> >> >
>> >> >
>> >> > _______________________________________________
>> >> > Users mailing list
>> >> > Users@ovirt.org
>> >> > http://lists.ovirt.org/mailman/listinfo/users
>> >> >
>> >> >
>> >> >
>> >> >
>> >> >
>> >> -------------- next part --------------
>> >> An HTML attachment was scrubbed...
>> >> URL:
>> >>
>> >> <http://lists.ovirt.org/pipermail/users/attachments/20161129/06bfe244/attachment.html>
>> >> -------------- next part --------------
>> >> A non-text attachment was scrubbed...
>> >> Name: pasted2
>> >> Type: image/png
>> >> Size: 108864 bytes
>> >> Desc: not available
>> >> URL:
>> >>
>> >> <http://lists.ovirt.org/pipermail/users/attachments/20161129/06bfe244/attachment.png>
>> >> -------------- next part --------------
>> >> A non-text attachment was scrubbed...
>> >> Name: pasted3
>> >> Type: image/png
>> >> Size: 135899 bytes
>> >> Desc: not available
>> >> URL:
>> >>
>> >> <http://lists.ovirt.org/pipermail/users/attachments/20161129/06bfe244/attachment-0001.png>
>> >>
>> >> ------------------------------
>> >>
>> >> _______________________________________________
>> >> Users mailing list
>> >> Users@ovirt.org
>> >> http://lists.ovirt.org/mailman/listinfo/users
>> >>
>> >>
>> >> End of Users Digest, Vol 62, Issue 197
>> >> **************************************
>> >
>> >
>> >
>> >
>> > --
>> > Shalabh Goel
>> >
>> > _______________________________________________
>> > Users mailing list
>> > Users@ovirt.org
>> > http://lists.ovirt.org/mailman/listinfo/users
>> >
>>
>>
>>
>> --
>> Didi
>
>
>
>
> --
> Shalabh Goel



-- 
Didi
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to