Hi Fernando,

There was a problem with the version you're using, the details can be found
here [1].

Please try to use a newer release of node-ng-4.1 for the upgrade.


[1] https://bugzilla.redhat.com/show_bug.cgi?id=1427468


On Wed, Mar 15, 2017 at 8:50 PM, FERNANDO FREDIANI <
fernando.fredi...@upx.com> wrote:

> Well, this failed badly.
> In another try it did the upgrade to the newer version it was not being
> able to do before, but upon reboot several services fail to start and the
> host doesn't come up. I then rebooted into the previous version.
>
> A complete re-install seems to be the only option.
> Seems the upgrade process need refining.
>
> Taking the opportunity what is the procedure to remove from the Engine a
> Host that will never come back up ? Seems the remove option is grayed when
> the server is offline or unreachable.
>
> Fernando
>
> On 15/03/2017 10:06, FERNANDO FREDIANI wrote:
>
> Find it attached Yuval.
>
> Fernando
>
>
> On 14/03/2017 18:21, Yuval Turgeman wrote:
>
> Adding Ryan, Fernando, can you please attach /tmp/imgbased.log ?
>
> On Mar 13, 2017 2:43 PM, "FERNANDO FREDIANI" <fernando.fredi...@upx.com>
> wrote:
>
>> Hi Yedidyah.
>> Running oVirt-Node *4.1.0--0.20170201.0+1* on the nodes and tried a
>> normal upgrade. It detected it has to upgrade to
>> *4.1.1-0.3.rc1.20170303133657.git20d3594.el7.centos* from the
>> ovirt-4.1-pre repository.
>>
>> The upgrade finished with the following problems:
>>
>> ...
>> Running transaction
>>   Updating   : ovirt-node-ng-image-4.1.1-0.3.
>> rc1.20170303133657.git20d3594.el7.centos.noarch
>> 1/4
>>   Updating   : ovirt-node-ng-image-update-4.1
>> .1-0.3.rc1.20170303133657.git20d3594.el7.centos.noarch
>> 2/4
>> mount: special device /dev/onn_kvm01/ovirt-node-ng-4.1.1-0.20170303.0+1
>> does not exist
>> cp: target ‘/tmp/tmp.N6JgSdFcu6/usr/share/imgbased/’ is not a directory
>> rm: cannot remove 
>> ‘/tmp/tmp.N6JgSdFcu6/usr/share/imgbased/*image-update*.rpm’:
>> No such file or directory
>> umount: /tmp/tmp.N6JgSdFcu6: not mounted
>> ...
>>
>> So it seems it was not able to do it correctly.
>> This is the second time it happens and I had to remove manually these
>> packages containing 4.1.1 version.
>>
>> Tried also:
>>
>> # lvdisplay | grep ovirt-node-ng-4.1.1-0.20170303.0+1
>>   LV Path                /dev/onn_kvm01/ovirt-node-ng-4
>> .1.1-0.20170303.0+1
>>   LV Name                ovirt-node-ng-4.1.1-0.20170303.0+1
>> # fdisk -l /dev/onn_kvm01/ovirt-node-ng-4.1.1-0.20170303.0+1
>> fdisk: cannot open /dev/onn_kvm01/ovirt-node-ng-4.1.1-0.20170303.0+1: No
>> such file or directory
>> # vgchange -ay
>> # fdisk -l /dev/onn_kvm01/ovirt-node-ng-4.1.1-0.20170303.0+1 (then
>> worked)
>> But the upon reboot it came back to 4.1.0 as if 4.1.1 never existed
>>
>> Fernando
>>
>> On 12/03/2017 03:30, Yedidyah Bar David wrote:
>>
>> On Fri, Mar 10, 2017 at 2:37 PM, FERNANDO 
>> FREDIANI<fernando.fredi...@upx.com> <fernando.fredi...@upx.com> wrote:
>>
>> I am not sure if another email I sent went through but has anyone got
>> problems when upgrading a running oVirt-node-ng from 4.1.0 to 4.1.1.
>>
>> What kind of problems?
>>
>>
>> Is the only solution a complete reinstall of the node ?
>>
>> No, this should work.
>>
>> Best,
>>
>>
>> Thanks
>>
>> Fernando
>>
>> _______________________________________________
>> Users mailing 
>> listUsers@ovirt.orghttp://lists.ovirt.org/mailman/listinfo/users
>>
>> _______________________________________________ Users mailing list
>> Users@ovirt.org http://lists.ovirt.org/mailman/listinfo/users
>
>
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to