On Thu, Apr 20, 2017 at 7:19 PM, Gianluca Cecchi <gianluca.cec...@gmail.com>
wrote:

> On Wed, Apr 19, 2017 at 4:26 PM, Arsène Gschwind <
> arsene.gschw...@unibas.ch> wrote:
>
>> I did start the hosted engine on the host I've applied the patch but I've
>> forgot to restart ovirt-ha-agent, and now it works.
>>
>> Great job, thanks
>>
>> Best regards,
>> Arsène
>>
>>
> Hello,
> I have the same on my single host hosted engine environment, after passing
> from 4.1.0 to 4.1.1
>
>
>
>
BTW the qemu command line generated for hosted engine is :

qemu     23686     1 82 19:11 ?        00:00:15 /usr/libexec/qemu-kvm -name
guest=HostedEngine,debug-threads=on -S -object
secret,id=masterKey0,format=raw,file=/var/lib/libvirt/qemu/domain-8-HostedEngine/master-key.aes
-machine pc-i440fx-rhel7.3.0,accel=kvm,usb=off -cpu Nehalem -m 16384
-realtime mlock=off -smp 4,maxcpus=16,sockets=16,cores=1,threads=1 -uuid
7b0ff898-0a9e-4b97-8292-1d9f2a0a6683 -smbios
type=1,manufacturer=oVirt,product=oVirt
Node,version=7-3.1611.el7.centos,serial=4C4C4544-0054-5910-8056-C4C04F30354A,uuid=7b0ff898-0a9e-4b97-8292-1d9f2a0a6683
-nographic -no-user-config -nodefaults -chardev
socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-8-HostedEngine/monitor.sock,server,nowait
-mon chardev=charmonitor,id=monitor,mode=control -rtc
base=2017-04-20T17:11:49,driftfix=slew -global
kvm-pit.lost_tick_policy=discard -no-hpet -no-reboot -boot strict=on
-device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device
virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x4 -device
virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x5 -drive
file=/var/run/vdsm/storage/2025c2ea-6205-4bc1-b29d-745b47f8f806/d6287dfb-27af-461b-ab79-4eb3a45d8c8a/43ee87b9-4293-4d43-beab-582f500667a7,format=raw,if=none,id=drive-virtio-disk0,serial=d6287dfb-27af-461b-ab79-4eb3a45d8c8a,cache=none,werror=stop,rerror=stop,aio=threads
-device
virtio-blk-pci,scsi=off,bus=pci.0,addr=0x6,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1
-drive if=none,id=drive-ide0-1-0,readonly=on -device
ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev
tap,fd=30,id=hostnet0,vhost=on,vhostfd=33 -device
virtio-net-pci,netdev=hostnet0,id=net0,mac=00:16:3e:3a:ee:a5,bus=pci.0,addr=0x3
-chardev
socket,id=charchannel0,path=/var/lib/libvirt/qemu/channels/7b0ff898-0a9e-4b97-8292-1d9f2a0a6683.com.redhat.rhevm.vdsm,server,nowait
-device
virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm
-chardev
socket,id=charchannel1,path=/var/lib/libvirt/qemu/channels/7b0ff898-0a9e-4b97-8292-1d9f2a0a6683.org.qemu.guest_agent.0,server,nowait
-device
virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=org.qemu.guest_agent.0
-chardev
socket,id=charchannel2,path=/var/lib/libvirt/qemu/channels/7b0ff898-0a9e-4b97-8292-1d9f2a0a6683.org.ovirt.hosted-engine-setup.0,server,nowait
-device
virtserialport,bus=virtio-serial0.0,nr=3,chardev=charchannel2,id=channel2,name=org.ovirt.hosted-engine-setup.0
-chardev pty,id=charconsole0 -device
virtconsole,chardev=charconsole0,id=console0 -object
rng-random,id=objrng0,filename=/dev/urandom -device
virtio-rng-pci,rng=objrng0,id=rng0,bus=pci.0,addr=0x2 -msg timestamp=on


and in /var/log/libvirt/qemu/HostedEngine.log

2017-04-20 17:11:49.947+0000: starting up libvirt version: 2.0.0, package:
10.el7_3.5 (CentOS BuildSystem <http://bugs.centos.org>,
2017-03-03-02:09:45, c1bm.rdu2.centos.org), qemu version: 2.6.0
(qemu-kvm-ev-2.6.0-28.el7_3.6.1), hostname: ractor.mydomain
LC_ALL=C PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin
QEMU_AUDIO_DRV=none /usr/libexec/qemu-kvm -name
guest=HostedEngine,debug-threads=on -S -object
secret,id=masterKey0,format=raw,file=/var/lib/libvirt/qemu/domain-8-HostedEngine/master-key.aes
-machine pc-i440fx-rhel7.3.0,accel=kvm,usb=off -cpu Nehalem -m 16384
-realtime mlock=off -smp 4,maxcpus=16,sockets=16,cores=1,threads=1 -uuid
7b0ff898-0a9e-4b97-8292-1d9f2a0a6683 -smbios
'type=1,manufacturer=oVirt,product=oVirt
Node,version=7-3.1611.el7.centos,serial=4C4C4544-0054-5910-8056-C4C04F30354A,uuid=7b0ff898-0a9e-4b97-8292-1d9f2a0a6683'
-nographic -no-user-config -nodefaults -chardev
socket,id=charmonitor,path=/var/lib/libvirt/qemu/domain-8-HostedEngine/monitor.sock,server,nowait
-mon chardev=charmonitor,id=monitor,mode=control -rtc
base=2017-04-20T17:11:49,driftfix=slew -global
kvm-pit.lost_tick_policy=discard -no-hpet -no-reboot -boot strict=on
-device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device
virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x4 -device
virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x5 -drive
file=/var/run/vdsm/storage/2025c2ea-6205-4bc1-b29d-745b47f8f806/d6287dfb-27af-461b-ab79-4eb3a45d8c8a/43ee87b9-4293-4d43-beab-582f500667a7,format=raw,if=none,id=drive-virtio-disk0,serial=d6287dfb-27af-461b-ab79-4eb3a45d8c8a,cache=none,werror=stop,rerror=stop,aio=threads
-device
virtio-blk-pci,scsi=off,bus=pci.0,addr=0x6,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1
-drive if=none,id=drive-ide0-1-0,readonly=on -device
ide-cd,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev
tap,fd=30,id=hostnet0,vhost=on,vhostfd=33 -device
virtio-net-pci,netdev=hostnet0,id=net0,mac=00:16:3e:3a:ee:a5,bus=pci.0,addr=0x3
-chardev
socket,id=charchannel0,path=/var/lib/libvirt/qemu/channels/7b0ff898-0a9e-4b97-8292-1d9f2a0a6683.com.redhat.rhevm.vdsm,server,nowait
-device
virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=com.redhat.rhevm.vdsm
-chardev
socket,id=charchannel1,path=/var/lib/libvirt/qemu/channels/7b0ff898-0a9e-4b97-8292-1d9f2a0a6683.org.qemu.guest_agent.0,server,nowait
-device
virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=org.qemu.guest_agent.0
-chardev
socket,id=charchannel2,path=/var/lib/libvirt/qemu/channels/7b0ff898-0a9e-4b97-8292-1d9f2a0a6683.org.ovirt.hosted-engine-setup.0,server,nowait
-device
virtserialport,bus=virtio-serial0.0,nr=3,chardev=charchannel2,id=channel2,name=org.ovirt.hosted-engine-setup.0
-chardev pty,id=charconsole0 -device
virtconsole,chardev=charconsole0,id=console0 -object
rng-random,id=objrng0,filename=/dev/urandom -device
virtio-rng-pci,rng=objrng0,id=rng0,bus=pci.0,addr=0x2 -msg timestamp=on
char device redirected to /dev/pts/1 (label charconsole0)

also I have this:

[root@ractor ~]# hosted-engine --add-console-password --password=pippo
no graphics devices configured
[root@ractor ~]#
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to