Thank you!
I will give a try.
Best,
Latcho

From: Pavol Brilla [mailto:pbri...@redhat.com]
Sent: Wednesday, May 31, 2017 4:05 PM
To: Christopher Young
Cc: Latchezar Filtchev; users@ovirt.org
Subject: Re: [ovirt-users] PXE boot of oVirt Node 4.1

Hi

Information on ovirt.org<http://ovirt.org> is about old node, from oVirt 4.0 we 
have NextGeneration Node (NGN). I don't  use cobbler, but for PXE I can provide 
what worked for me.
Take iso from: 
http://resources.ovirt.org/pub/ovirt-4.1/iso/ovirt-node-ng-installer/, unpack 
it ( simple mount -o loop; cp -r ):

pxelinux.cfg/ovirt-node.menu:
...
LABEL ovirt NGN
        KERNEL http://websrv/your_unpacked_iso/images/pxeboot/vmlinuz
        APPEND initrd=http://websrv/your_unpacked_iso/images/pxeboot/initrd.img 
inst.stage2=http://websrv/your_unpacked_iso/ 
inst.ks=http://websrv/your_unpacked_iso/my.ks
        ipappend 2


Kickstart file to automate a lot of tasks for me "my.ks":
​​install
lang en_US.UTF-8
keyboard us
rootpw  --plaintext 123
network --bootproto=dhcp
timezone --utc Europe/Prague
firewall --service=ssh

liveimg --url=http://websrv/your_unpacked_iso/ovirt-node-ng-image.squashfs.img

# partitioning - nuke and start fresh
zerombr
clearpart --all --initlabel
autopart --type=thinp
bootloader --location=mbr

reboot

%post --erroronfail
imgbase layout --init
%end


Basically liveimg --url ... & autopart & %post part should be enough for 
interactive install.
I hope I made it at least a little bit clearer.

​
--
Pavol Brilla

On Thu, May 25, 2017 at 5:41 PM, Christopher Young 
<mexigaba...@gmail.com<mailto:mexigaba...@gmail.com>> wrote:
I've been wondering the same.  In particular, I use cobbler for system
provisioning, so would love to have some details to help me implement
this.

On Thu, May 25, 2017 at 10:49 AM, Latchezar Filtchev 
<lat...@aubg.bg<mailto:lat...@aubg.bg>> wrote:
> Hello oVirt-ers,
>
>
>
> Did someone was able to install oVirt node 4.1 -
> ovirt-node-ng-installer-ovirt-4.1-2017051704<tel:1-2017051704>.iso via 
> pxe/tftp boot?
>
>
>
> This works http://www.ovirt.org/develop/projects/node/pxe/ for oVirt 3.4
>
> When using the same approach for oVirt 4.0 and oVirt 4.1 the computer hangs.
>
> Any help will be appreciated.
>
>
>
>
>
> Thank you!
>
> Best,
>
> Latcho
>
>
>
>
>
>
> _______________________________________________
> Users mailing list
> Users@ovirt.org<mailto:Users@ovirt.org>
> http://lists.ovirt.org/mailman/listinfo/users
>
_______________________________________________
Users mailing list
Users@ovirt.org<mailto:Users@ovirt.org>
http://lists.ovirt.org/mailman/listinfo/users
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to