Hi Jenny,

> What version are you running?

4.1.2.2-1.el7.centos

> For the hosted engine vm to be imported and displayed in the engine, you
> must first create a master storage domain.

To provide a bit more detail: this was a migration of a bare-metal
engine in an existing cluster to a hosted engine VM for that cluster.
As part of this migration, I built an entirely new host and ran
'hosted-engine --deploy' (followed these instructions:
http://www.ovirt.org/documentation/self-hosted/chap-Migrating_from_Bare_Metal_to_an_EL-Based_Self-Hosted_Environment/).
I restored the backup from the engine and it completed without any
errors. I didn't see any instructions regarding a master storage
domain in the page above. The cluster has two existing master storage
domains, one is fibre channel, which is up, and one ISO domain, which
is currently offline.

> What do you mean the hosted engine commands are failing? What happens when
> you run hosted-engine --vm-status now?

Interestingly, whereas when I ran it before, it exited with no output
and a return code of '1', it now reports:

--== Host 1 status ==--

conf_on_shared_storage             : True
Status up-to-date                  : False
Hostname                           : kvm-ldn-03.ldn.fscfc.co.uk
Host ID                            : 1
Engine status                      : unknown stale-data
Score                              : 0
stopped                            : True
Local maintenance                  : False
crc32                              : 0217f07b
local_conf_timestamp               : 2911
Host timestamp                     : 2897
Extra metadata (valid at timestamp):
        metadata_parse_version=1
        metadata_feature_version=1
        timestamp=2897 (Thu Jun 15 16:22:54 2017)
        host-id=1
        score=0
        vm_conf_refresh_time=2911 (Thu Jun 15 16:23:08 2017)
        conf_on_shared_storage=True
        maintenance=False
        state=AgentStopped
        stopped=True

Yet I can login to the web GUI fine. I guess it is not HA due to being
in an unknown state currently? Does the hosted-engine-ha rpm need to
be installed across all nodes in the cluster, btw?

Thanks for the help,

Cam

>
> Jenny Tokar
>
>
> On Thu, Jun 15, 2017 at 6:32 PM, cmc <iuco...@gmail.com> wrote:
>>
>> Hi,
>>
>> I've migrated from a bare-metal engine to a hosted engine. There were
>> no errors during the install, however, the hosted engine did not get
>> started. I tried running:
>>
>> hosted-engine --status
>>
>> on the host I deployed it on, and it returns nothing (exit code is 1
>> however). I could not ping it either. So I tried starting it via
>> 'hosted-engine --vm-start' and it returned:
>>
>> Virtual machine does not exist
>>
>> But it then became available. I logged into it successfully. It is not
>> in the list of VMs however.
>>
>> Any ideas why the hosted-engine commands fail, and why it is not in
>> the list of virtual machines?
>>
>> Thanks for any help,
>>
>> Cam
>> _______________________________________________
>> Users mailing list
>> Users@ovirt.org
>> http://lists.ovirt.org/mailman/listinfo/users
>
>
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to