On Fri, Jun 23, 2017 at 4:24 PM, Vinícius Ferrão <fer...@if.ufrj.br> wrote:

> Hello Adam,
>
> Since the NFSv3 server is running on a FreeBSD based system I don’t want
> to mess with permissions (that installation was only a test). So I’ve
> mapped all users to root and all groups to wheel: everyone has permission
> to do anything on any file.
>
> # cat /etc/exports
> /mnt/pool/ovirt  -alldirs -mapall=root:wheel 146.164.36.137
>

I think this might be part of your problem.  The host drops privileges to
vdsm:kvm and needs to work with files which may not be world writable.
Consider changing the above to:

/mnt/pool/ovirt  -alldirs -mapall=36:36 146.164.36.137

Since the vdsm user is always 36 and the kvm group is always 36.


> The issue happens on the same point, either on NFS or on iSCSI.
>
> And finally here are the files:
> http://www.if.ufrj.br/~ferrao/ovirt/
>
>
>From the sanlock log I can see host id renewal failures which are resulting
in vdsm being killed.  That's why we are seeing the timeouts of the API
calls.  My first guess is this is a permissions error (although I am not
sure why it would also fail with iscsi).


> Thanks,
> V.
>
> On 23 Jun 2017, at 17:16, Adam Litke <ali...@redhat.com> wrote:
>
> Please provide links to the files /var/log/vdsm/vdsm.log
> and /var/log/sanlock.log on the host you are attempting to use.  Does the
> problem happen in the same step when using NFS vs. ISCSI?  How are you
> configuring the NFS export that you give to hosted-engine to use?
>
> On Fri, Jun 23, 2017 at 2:53 PM, Vinícius Ferrão <fer...@if.ufrj.br>
> wrote:
>
>> Hello oVirt folks.
>>
>> I’m a traitor of the Xen movement and was looking for some good
>> alternatives for XenServer hypervisors. I was aware of KVM for a long time
>> but I was missing a more professional and appliance feeling of the product,
>> and oVirt appears to deliver exactly what I’m looking for.
>>
>> Don’t get me wrong, I’m not saying that Xen is not good, I’m looking for
>> equal or better alternatives, but I’m starting to get frustrated with oVirt.
>>
>> Firstly I’ve tried to install the oVirt Node on a VM in VMware Fusion on
>> my notebook, it was a no go. For whatever reasons I don’t know
>> vdsmd.service and libvirtd failed to start. I make sure that I was running
>> with EPT support enabled to achieve nested virtualization, but as I said:
>> it was a no go.
>>
>> So I’ve decommissioned a XenServer machine that was in production just to
>> try oVirt. The hardware is not new, but’s it’s very capable: Dual Xeon
>> E5506 with 48GB of system RAM, but I can’t get the hosted engine to work,
>> it always insults my hardware: --- Hosted Engine deployment failed: this
>> system is not reliable, please check the issue,fix and redeploy.
>>
>> It’s definitely a problem on the storage subsystem, the error is just
>> random, at this moment I’ve got:
>>
>> [ ERROR ] Failed to execute stage 'Misc configuration': [-32605] No
>> response for JSON-RPC StorageDomain.detach request.
>>
>> But on other tries it came up with something like this:
>>
>> No response for JSON-RPC Volume.getSize request.
>>
>> I was thinking that the problem was on the NFSv3 server on our FreeNAS
>> box, so I’ve changed to an iSCSI backend, but the problem continues. This
>> happens at the very end of the ovirt-hosted-engine-setup command, which
>> leads me to believe that’s an oVirt issue. The OVA was already copied and
>> deployed to the storage:
>>
>> [ INFO  ] Starting vdsmd
>> [ INFO  ] Creating Volume Group
>> [ INFO  ] Creating Storage Domain
>> [ INFO  ] Creating Storage Pool
>> [ INFO  ] Connecting Storage Pool
>> [ INFO  ] Verifying sanlock lockspace initialization
>> [ INFO  ] Creating Image for 'hosted-engine.lockspace' ...
>> [ INFO  ] Image for 'hosted-engine.lockspace' created successfully
>> [ INFO  ] Creating Image for 'hosted-engine.metadata' ...
>> [ INFO  ] Image for 'hosted-engine.metadata' created successfully
>> [ INFO  ] Creating VM Image
>> [ INFO  ] Extracting disk image from OVF archive (could take a few
>> minutes depending on archive size)
>> [ INFO  ] Validating pre-allocated volume size
>> [ INFO  ] Uploading volume to data domain (could take a few minutes
>> depending on archive size)
>> [ INFO  ] Image successfully imported from OVF
>> [ ERROR ] Failed to execute stage 'Misc configuration': [-32605] No
>> response for JSON-RPC StorageDomain.detach request.
>> [ INFO  ] Yum Performing yum transaction rollback
>> [ INFO  ] Stage: Clean up
>> [ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-
>> setup/answers/answers-20170623032541.conf'
>> [ INFO  ] Stage: Pre-termination
>> [ INFO  ] Stage: Termination
>> [ ERROR ] Hosted Engine deployment failed: this system is not reliable,
>> please check the issue,fix and redeploy
>>           Log file is located at /var/log/ovirt-hosted-engine-s
>> etup/ovirt-hosted-engine-setup-20170623023424-o9rbt0.log
>>
>> At this point I really don’t know what I should try. And the log file is
>> too verborragic (hoping this word exists) to look for errors.
>>
>> Any guidance?
>>
>> Thanks,
>> V.
>>
>> _______________________________________________
>> Users mailing list
>> Users@ovirt.org
>> http://lists.ovirt.org/mailman/listinfo/users
>>
>
>
>
> --
> Adam Litke
>
>
>


-- 
Adam Litke
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to