Hi Yaniv,

I have enabled random generator in cluster and also in VM.
But still not see any improvement in throughput.

lsmod | grep -i virtio
virtio_rng             13019  0
virtio_balloon         13834  0
virtio_console         28115  2
virtio_blk             18156  4
virtio_scsi            18361  0
virtio_net             28024  0
virtio_pci             22913  0
virtio_ring            21524  7
virtio_blk,virtio_net,virtio_pci,virtio_rng,virtio_balloon,virtio_console,virtio_scsi
virtio                 15008  7
virtio_blk,virtio_net,virtio_pci,virtio_rng,virtio_balloon,virtio_console,virtio_scsi

Would please check do I missing some virtio module ?

One more finding, if I set queue property in vnic profile then I got good
throughput.

Thanks,
~Rohit


On Fri, Jun 30, 2017 at 12:11 AM, Yaniv Kaul <yk...@redhat.com> wrote:

>
>
> On Thu, Jun 29, 2017 at 4:02 PM, TranceWorldLogic . <
> tranceworldlo...@gmail.com> wrote:
>
>> Got it, just I need to do modprobe to add virtio-rng driver.
>> I will try with this option.
>>
>
> Make sure it is checked on the cluster.
> Y.
>
>>
>> Thanks for your help,
>> ~Rohit
>>
>> On Thu, Jun 29, 2017 at 6:20 PM, TranceWorldLogic . <
>> tranceworldlo...@gmail.com> wrote:
>>
>>> Hi,
>>>
>>> I am using host as Centos 7.3 and guest also centos 7.3
>>> it have 3.10 kernel version.
>>>
>>> But I not see virtio-rng in guest VM. Is this module come with kernel or
>>> separately I have to install ?
>>>
>>> Thanks,
>>> ~Rohit
>>>
>>> On Thu, Jun 29, 2017 at 5:28 PM, Yaniv Kaul <yk...@redhat.com> wrote:
>>>
>>>>
>>>>
>>>> On Thu, Jun 29, 2017 at 10:07 AM, TranceWorldLogic . <
>>>> tranceworldlo...@gmail.com> wrote:
>>>>
>>>>> Hi,
>>>>>
>>>>> To increase network throughput we have changed txqueuelen of network
>>>>> device and bridge manually. And observed  improved throughput.
>>>>>
>>>>
>>>> Interesting, as I've read the default (1000) should be good enough for
>>>> 10g, for example.
>>>>
>>>> Are you actually seeing errors on the interface (overruns) and such?
>>>>
>>>>
>>>>>
>>>>> But in ovirt I not see any option to increase txqueuelen.
>>>>>
>>>>
>>>> Perhaps use ifup-local script to set it when the interface goes up?
>>>>
>>>>
>>>>> Can someone suggest me what will be the right way to increase
>>>>> throughput ?
>>>>>
>>>>> Note: I am trying to increase throughput for  ipsec packets.
>>>>>
>>>>
>>>> For ipsec, probably best to ensure virtio-rng is enabled.
>>>> Y.
>>>>
>>>>
>>>>>
>>>>> Thanks,
>>>>> ~Rohit
>>>>>
>>>>> _______________________________________________
>>>>> Users mailing list
>>>>> Users@ovirt.org
>>>>> http://lists.ovirt.org/mailman/listinfo/users
>>>>>
>>>>>
>>>>
>>>
>>
>
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to