Hi yayo,

Based off of the information you've provided here, it doesn't sound like
the deployment was successful despite being able to access the web
interface. You can check the status of the deployment from node01 by
running 'hosted-engine --check-deployed'. You can also check the status of
the VM by running 'hosted-engine --vm-status'. Could you run those commands
and provide the output? It would also be helpful if you could provide the
log indicated at the end of the deploy script.

As far as the storage issue, you must have an active host in order to add a
storage/data domain. Typically, the first data domain added will become the
master data domain, which will be indicated in the web interface by
'(Master)' following the type in the Domain Type column in the Storage main
tab. The host that was selected during the domain setup will become the
Storage Pool Manager (SPM) and will have 'SPM' in the SPM column in the
Hosts main tab. If you attempt to move this host to maintenance mode,
another host will be selected to become the SPM. If no other hosts are
available, I believe you'll get an error message which will prevent you
from being able to move it to maintenance. I believe in this situation you
can put the storage domain into maintenance mode by going to the Storage
sub tab under the Data Center main tab, selecting the domain, and clicking
the 'Maintenance' button. This should allow you to then put the last host
into maintenance mode.

However, I think your initial deployment needs to be fixed before adding
more hosts. Hopefully, I or someone else will be able to help you with that
once you've responded with the output from the status commands and the
setup log.

-Phillip Bailey

On Fri, Jul 7, 2017 at 7:22 AM, yayo (j) <jag...@gmail.com> wrote:

> Hi at all,
>
> I have correctly deployed an hosted engine using node01 via:
>
> hosted-engine --deploy
>
> Using FC shared storage.
>
> Seems all work good but, when I login in to the ovirt web interface I
> can't find the hosted engine under the VM tab (also the node01 server).
>
> So, I have tried to add node02 (no problem) and added the "Data Domain"
> storage (another FC share storage).
>
> Now (I Think) I needs to deploy also here the hosted engine but I can't.
> There is only one way, to put node02 in maintenance mode but, after that,
> "Data Domain" added going down and, when I try to deploy the hosted engine
> interface says:
>
>
> Error while executing action:
>
> node02:
> Cannot edit Host. You are using an unmanaged hosted engine VM. Please add
> the first storage domain in order to start the hosted engine import process.
>
> what is this "first storage domain"?
>
> I have not added the node01 yet because last time hosted engine crashed
> and the only way was to restart the installation ....
>
>
> Note: Hosted engine seems to be correcty deployed because all work good,
> but deploy script ended with error:
>
> [ INFO  ] Engine-setup successfully completed
> [ INFO  ] Engine is still unreachable
> [ INFO  ] Engine is still not reachable, waiting...
> [more of these messages]
> [ ERROR ] Engine is still not reachable
> [ ERROR ] Failed to execute stage 'Closing up': Engine is still not
> reachable
> [ INFO  ] Stage: Clean up
> [ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-
> setup/answers/answers-20170123113113.conf'
> [ INFO  ] Stage: Pre-termination
> [ INFO  ] Stage: Termination
> [ ERROR ] Hosted Engine deployment failed: this system is not reliable,
> please check the issue,fix and redeploy
>           Log file is located at /var/log/ovirt-hosted-engine-
> setup/ovirt-hosted-engine-setup-20170123105043-kvzx84.log
>
> Is related to this bug? https://bugzilla.redhat.com/
> show_bug.cgi?id=1415822
>
> _______________________________________________
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to