Hello Edward, this happened again today and I was able to check more details.

So:

- The VM stopped passing any network traffic.
- Checking 'brctl showmacs ovirtmgmt' it showed the VM's mac address missing. - I then went to oVirt Engine, under VM's 'Network Interfaces' tab, clicked Edit and changed the Link State to Down then to Up and it recovered its connectivity. - Another 'brctl showmacs ovirtmgmt' showed the VM's mac address learned again by the bridge.

This Node server has the particularity of sharing the ovirtmgmt with VMs. Could it possibly be the cause of the issue in any way ?

Thanks
Fernando


On 24/07/2017 09:47, FERNANDO FREDIANI wrote:

Not tried this yet Edwardh, but will do at next time it happens. THe source mac address should be the mac as the VM. I don't see any reason for it to change from within the VM ou outside.

What type of things would make the bridge stop learning a given VM mac address ?

Fernando


On 23/07/2017 07:51, Edward Haas wrote:
Have you tried to use tcpdump at the VM vNIC to examine if there is traffic trying to get out from there? And with what source mac address?

Thanks,
Edy,

On Fri, Jul 21, 2017 at 5:36 PM, FERNANDO FREDIANI <fernando.fredi...@upx.com <mailto:fernando.fredi...@upx.com>> wrote:

    Has anyone had problem when using the ovirtmgmt bridge to connect
    VMs ?

    I am still facing a bizarre problem where some VMs connected to
    this bridge stop passing traffic. Checking the problem further I
    see its mac address stops being learned by the bridge and the
    problem is resolved only with a VM reboot.

    When I last saw the problem I run brctl showmacs ovirtmgmt and it
    shows me the VM's mac adress with agening timer 200.19. After the
    VM reboot I see the same mac with agening timer 0.00.
    I don't see it in another environment where the ovirtmgmt is not
    used for VMs.

    Does anyone have any clue about this type of behavior ?

    Fernando
    _______________________________________________
    Users mailing list
    Users@ovirt.org <mailto:Users@ovirt.org>
    http://lists.ovirt.org/mailman/listinfo/users
    <http://lists.ovirt.org/mailman/listinfo/users>




_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to