Hi,
       You can follow the steps below to do that.

1) Stop all the virtual machines.

2) Move all the storage domains other than hosted_storage to maintenance
which will unmount them from all the nodes.

3)  Move HE to global maintenance 'hosted-engine --set-maintenance --mode
=global'

4) stop HE vm by running the command 'hosted-engine --vm-shutdown'

5) confirm that engine is down using the command 'hosted-engine --vm-status'

6) stop ha agent and broker services on all the nodes by running the
command 'systemctl stop ovirt-ha-broker' ; 'systemctl stop ovirt-ha-agent'

7) umount hosted-engine from all the hypervisors 'hosted-engine
--disconnect-storage'

8) stop all the volumes.

9) power off all the hypervisors.


To bring it up back again below steps will help.


1) Power on all the hypervisors.

2) start all the volumes

3) start ha agent and broker services on all the nodes by running the
command 'systemctl start ovirt-ha-broker' ; 'systemctl start ovirt-ha-agent'

4) Move hosted-engine out of global maintenance by running the command
hosted-engine
--set-maintenance --mode =none

5) give some time for the HE to come up. check for hosted-engine
--vm-status to see if HE vm is up.

6) Activate all storage domains from UI.

7) start all virtual machines.

Hope this helps !!!

Thanks

kasturi.

On Tue, Aug 8, 2017 at 2:27 AM, Moacir Ferreira <moacirferre...@hotmail.com>
wrote:

> Sorry Erekle, I am just a beginner...
>
>
> From the hosted engine I can put the two other servers, that are not
> hosting the hosted-engine, on maintenance, and that was what I did. When I
> tried to put the last one on maintenance it did not allow me due to the
> hosted-engine and I force it shunting down from the ssh CLI.
>
>
> So, what should I do? My guess is that I should ssh to the hosted engine
> and shut it down. As it would not have another node to re-launch itself,
> then it would stay down. After this I should shutdown the oVirt node. Is it?
>
>
> Anyway, I made a mistake and I forced it. When I try to bring the cluster
> back, I noticed that glusterd was not enabled to start when the node
> power-on. As I am a beginner, I "think" that there must be a reason to not
> start glusterd when the node comes up. So I started glusterd on the
> arbitrator (3rd server), then on the second node and finally on the host
> that was hosting the hosted-engine. It worked, but when I try to change the
> maintenance mode on the two nodes (2nd and 3rd) back to normal, the
> hosted-engine went down and I had to start it manually.
>
>
> All this said, I would like to know how to bring the cluster down and how
> to bring it back on in the "right way" so I don't get problems. And yes, no
> VM is running but the hosted-engine.
>
>
> Thanks for sharing your knowledge.
>
> Moacir
>
>
> ------------------------------
> *From:* Erekle Magradze <erekle.magra...@recogizer.de>
> *Sent:* Monday, August 7, 2017 9:12 PM
> *To:* Moacir Ferreira; users@ovirt.org
> *Subject:* Re: [ovirt-users] How to shutdown an oVirt cluster with
> Gluster and hosted engine
>
>
> Hi Moacir,
>
> First switch off all VMs.
>
> Second you need to declare hosts maintenance mode, don't start with SRM
> (of course if you are able use the ovirt-engine), it will ask you to
> shutdown the glusterfs on a machine.
>
> Third if all machines are in maintenance mode, you can start shutting down
> them.
>
>
> If you have hosted engine setup follow this [1]
>
>
> Cheers
>
> Erekle
>
>
> [1] https://github.com/rharmonson/richtech/wiki/OSVDC-Series:-
> oVirt-3.6-Cluster-Shutdown-and-Startup
>
> <https://github.com/rharmonson/richtech/wiki/OSVDC-Series:-oVirt-3.6-Cluster-Shutdown-and-Startup>
> OSVDC Series: oVirt 3.6 Cluster Shutdown and Startup ...
> <https://github.com/rharmonson/richtech/wiki/OSVDC-Series:-oVirt-3.6-Cluster-Shutdown-and-Startup>
> github.com
> Contribute to richtech development by creating an account on GitHub.
>
> On 08/07/2017 08:58 PM, Moacir Ferreira wrote:
>
> I have installed a oVirt cluster in a KVM virtualized test environment.
> Now, how do I properly shutdown the oVirt cluster, with Gluster and the
> hosted engine?
>
> I.e.: I want to install a cluster of 3 servers and then send it to a
> remote office. How do I do it properly? I noticed that glusterd is not
> enabled to start automatically. And how do I deal with the hosted engine?
>
>
> Thanks,
>
> Moacir
>
>
> _______________________________________________
> Users mailing listUsers@ovirt.orghttp://lists.ovirt.org/mailman/listinfo/users
>
>
> --
> Recogizer Group GmbH
>
> Dr.rer.nat. Erekle Magradze
> Lead Big Data Engineering & DevOps
> Rheinwerkallee 2, 53227 Bonn
> Tel: +49 228 29974555
>
> E-Mail erekle.magra...@recogizer.de
> Web: www.recogizer.com
>
> Recogizer auf LinkedIn https://www.linkedin.com/company-beta/10039182/
> Folgen Sie uns auf Twitter https://twitter.com/recogizer
>
> -----------------------------------------------------------------
> Recogizer Group GmbH
> Geschäftsführer: Oliver Habisch, Carsten Kreutze
> Handelsregister: Amtsgericht Bonn HRB 20724
> Sitz der Gesellschaft: Bonn; USt-ID-Nr.: DE294195993
>
> Diese E-Mail enthält vertrauliche und/oder rechtlich geschützte Informationen.
> Wenn Sie nicht der richtige Adressat sind oder diese E-Mail irrtümlich 
> erhalten haben,
> informieren Sie bitte sofort den Absender und löschen Sie diese Mail.
> Das unerlaubte Kopieren sowie die unbefugte Weitergabe dieser Mail und der 
> darin enthaltenen Informationen ist nicht gestattet.
>
>
> _______________________________________________
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to