On Friday, November 3, 2017 1:41:00 PM EDT ~Stack~ wrote:
> On 11/03/2017 12:23 PM, Alexander Wels wrote:
> > On Friday, November 3, 2017 1:15:27 PM EDT ~Stack~ wrote:
> >> Greetings,
> >> 
> >> I'm seriously just grasping at straws here. I took a spare hard drive,
> >> tossed it in the management host, and did a fresh install. It did not
> >> like me trying to add it into the existing infrastructure. Tried to dump
> >> the DB from the old to the new, update the passwords, and pretty much
> >> ended up in the same place.
> >> 
> >> I did check the .trustedkeystore and it has the same 1 key as my
> >> original back up. So that isn't the issue.
> >> 
> >> Still poking at it. Would love some thoughts/feedback.
> >> 
> >> Thanks!
> >> ~Stack~
> > 
> > Running engine-setup on the engine machine should re-generate the keys.
> 
> Thanks for the suggestion. I've tried that. Twice. Still the same error.
> 
> "Keystore was tampered with, or password was incorrect."
> 
> From digging around in the logs, it looks like it is trying to access
> /etc/pki/ovirt-engine/.trustedstore but the password found in the ovirt
> configs works just fine. So I know it is not a password issue.
> 
> I've been trying to figure out how that file is created so I can
> possibly generate a new one, but no luck so far.
> 
> Thanks!
> ~Stack~

AFAIC engine-setup will create the files needed. Try running engine-cleanup 
and maybe it will remove everything needed and then running engine-setup 
again?

But if all else fails you should be able to create a fresh engine, and after 
you have added a host, you should be able to import the existing storage 
domain (like you noted the VMs are still there).

_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to