On Mon, Jan 8, 2018 at 1:36 AM, Sam McLeod <mailingli...@smcleod.net> wrote:

> Thank you for the information Dan, Dominik and Didi,
> To avoid logging yet another bug for this issue, I've updated bug
> https://bugzilla.redhat.com/show_bug.cgi?id=1459229 as you've mentioned
> with the brief of our conversation here.
> By the way, it is very useful to name a bonded interface things other than
> bondXYZ, for example, you might have 6 bonds, each of a different network
> or native VLAN.
> It helps with debugging, troubleshooting and logging if the interface is
> named after the (native) network, e.g. your iSCSI storage network might
> have a bond called 'storage', while your management or hypervisor network
> might have a bond named 'mgmt' then perhaps you have 'data' bond that might
> have several vlans off it such as 'db' (database), 'dmz', 'staff' etc...
> depending on how and where you chop your network up.

When I was a sysadmin I used to call my bonds bondFUNCTION.

This way I both had a prefix 'bond' that readily showed it's
a bond, and a suffix showing its function.

IMO oVirt should allow any bond names. If we do decide to limit
them at all, I'd limit only in a negative way - what's not
allowed. E.g. it makes sense to me if we reject prefixes that
are common for non-bonds (eth, en, wl, br etc), but even that
I am not sure is so important.

> --
> Sam McLeod
> https://smcleod.net
> https://twitter.com/s_mcleod
> On 7 Jan 2018, at 6:08 pm, Yedidyah Bar David <d...@redhat.com> wrote:
> On Fri, Jan 5, 2018 at 7:44 AM, Dan Kenigsberg <dan...@redhat.com> wrote:
>> On Thu, Jan 4, 2018 at 5:50 AM, Sam McLeod <mailingli...@smcleod.net>
>> wrote:
>> > I'm having a problem where when setting up hosted engine deployment it
>> fails
>> > stating that the selected bond name is bad.
>> >
>> > "code=25, message=bad bond name(s): mgmt)"
>> >
>> > - Is there a problem similar to
>> > https://bugzilla.redhat.com/show_bug.cgi?id=1519807 that's known?
> Please note that this is just but one bug in a series/tree of
> related bugs, some of which are open. If you decide to follow
> Dan's suggestion, perhaps reuse one of the others, or perhaps
> even better - open a new one, and eventually one or more will
> be closed as duplicate of one or more of the others. Sadly,
> not all of them link properly to each other, and at least one
> which was fixed caused another bug, so the fix was reverted.
> See also e.g. all of the discussion in:
> https://bugzilla.redhat.com/show_bug.cgi?id=1459229
>> > - If it seems to be this bug, is it preferred that I simply update the
>> > existing, closed issue as I have done, or open a new bug?
>> >
>> > --
>> > Sam McLeod
>> > https://smcleod.net
>> > https://twitter.com/s_mcleod
>> I see that you are trying to use a bond interface named "mgmt".
>> To avoid confusion while debugging a system, Vdsm has opted to allow
>> only bond names starting with "bond" followed by one or more decimal
>> digits. Anything else is considered "bad bond".
>> I prefer keeping the "bond" prefix compulsory, but I'd like to hear
>> why using different names is useful.
>> You can reopen this bug, but please move it to vdsm and rename it: it
>> should be something like "Allow any bondXYZ name for bonds" or "Allow
>> any bond name" and explain there why it is a good idea.
>> Dominik, is there an Engine-side limitation on bond names?
>> _______________________________________________
>> Users mailing list
>> Users@ovirt.org
>> http://lists.ovirt.org/mailman/listinfo/users
> --
> Didi

Users mailing list

Reply via email to