I haven't tried to build on EL for a long time, but the easiest way to
modify may simply be to unpack the squashfs, chroot inside of it, and
repack it. Have you tried this?

On Wed, Dec 27, 2017 at 11:33 AM, Giuseppe Ragusa <
giuseppe.rag...@hotmail.com> wrote:

> Hi all,
>
> I'm trying to modify the oVirt NGN image (to add RPMs, since imgbased
> rpmpersistence currently seems to have a bug: https://bugzilla.redhat.com/
> show_bug.cgi?id=1528468 ) but I'm unfortunately stuck at the very
> beginning: it seems that I'm unable to recreate even the standard 4.1
> squashfs image.
>
> I'm following the instructions at https://gerrit.ovirt.org/
> gitweb?p=ovirt-node-ng.git;a=blob;f=README
>
> I'm working inside a CentOS7 fully-updated vm (hosted inside VMware, with
> nested virtualization enabled).
>
> I'm trying to work on the 4.1 branch, so I issued a:
>
> ./autogen.sh --with-ovirt-release-rpm-url=http://resources.ovirt.org/pub/
> yum-repo/ovirt-release41.rpm
>
> And after that I'm stuck in the "make squashfs" step: it never ends (keeps
> printing dots forever with no errors/warnings in log messages nor any
> apparent activity on the virtual disk image).
>
> Invoking it in debug mode and connecting to the VNC console shows the
> detailed Plymouth startup listing stuck (latest messages displayed:
> "Starting udev Wait for Complete Device Initialization..." and "Starting
> Device-Mapper Multipath Device Controller...")
>
> I wonder if it's actually supposed to be run only from a recent Fedora
> (the "dnf" reference seems a good indicator): if so, which version?
>
> I kindly ask for advice: has anyone succeeded in modifying/reproducing NGN
> squash images recently? If so, how? :-)
>
> Many thanks in advance,
>
> Giuseppe
> _______________________________________________
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>



-- 

RYAN BARRY

SENIOR SOFTWARE ENGINEER - TEAM LEAD - RHEV HYPERVISOR

Red Hat NA <https://www.redhat.com/>

rba...@redhat.com    M: +1-651-815-9306     IM: rbarry
<https://red.ht/sig>
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to