I have one node in our cluster that has problems when migrating a VM if the VM is hosted on a gluster volume.
If the VM is hosted on a NFS volume it migrates fine.

/var/log/messages:
Jan 16 14:36:09 ovirt1 libvirtd: 2018-01-16 22:36:09.769+0000: 9700: error : qemuProcessReportLogError:1862  : internal error: process exited while connecting to monitor: 2018-01-16T22:36:09.587405Z qemu-kvm: -drive
 
file=/rhev/data-center/8b6303b3-79c6-4633-ae21-71b15ed00675/67b4d9aa-f174-436a-b5a1-ec7cee5f2edb/images/60
3271e4-3089-4779-aa1c-faf280fabd17/7c7f7726-4ab0-4047-9b91-e0817a139e90,format=raw,if=none,id=drive-virtio-
disk0,serial=603271e4-3089-4779-aa1c-faf280fabd17,cache=none,werror=stop,rerror=stop,aio=threads: Could not  open '/rhev/data-center/8b6303b3-79c6-4633-ae21-71b15ed00675/67b4d9aa-f174-436a-b5a1-ec7cee5f2edb/images/603271e4-3089-4779-aa1c-faf280fabd17/7c7f7726-4ab0-4047-9b91-e0817a139e90': Permission denied
(libvirt/csapi1.test.j2noc.com.log says same thing)

[root@ovirt1 test log]# ls -hl /rhev/data-center/8b6303b3-79c6-4633-ae21-71b15ed00675/67b4d9aa-f174-436a-b5a1-ec7cee5f2edb/images/603271e4-3089-4779-aa1c-faf280fabd17/7c7f7726-4ab0-4047-9b91-e0817a139e90 -rw-rw---- 1 vdsm kvm 20G Jan 16 15:32 /rhev/data-center/8b6303b3-79c6-4633-ae21-71b15ed00675/67b4d9aa-f174-436a-b5a1-ec7cee5f2edb/images/603271e4-3089-4779-aa1c-faf280fabd17/7c7f7726-4ab0-4047-9b91-e0817a139e90

lrwxrwxrwx 1 vdsm kvm  98 Jan 10 21:21 67b4d9aa-f174-436a-b5a1-ec7cee5f2edb -> /rhev/data-center/mnt/glusterSD/ovirt3-ks.test.j2noc.com:_gv3/67b4d9aa-f174-436a-b5a1-ec7cee5f2edb


engine.log:
2018-01-16 14:36:18,846-08 WARN [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (o rg.ovirt.thread.pool-6-thread-34) [78d8b38c] EVENT_ID: VM_MIGRATION_TRYING_RERUN(128), Correlation ID: e39 9da53-cd31-401c-bf63-16b118b8884c, Job ID: 4db6bd87-0da4-4358-acae-dc453c813969, Call Stack: null, Custom ID: null, Custom Event ID: -1, Message: Failed to migrate VM csapi1.test.j2noc.com to Host ovirt1.test.j2n
oc.com . Trying to migrate to another Host.


ovirt-engine-tools-4.1.8.2-1.el7.centos.noarch
glusterfs-3.8.15-2.el7.x86_64
vdsm-4.19.43-1.el7.centos.x86_64
libvirt-daemon-3.2.0-14.el7_4.7.x86_64

Let me know what logs would be useful in troubleshooting this.

Thanks!


_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to