Hi,

following the oVirt upgrade procedure on a CentOS system (https://www.ovirt.org/release/4.2.0/#centos--rhel) I fail at step `yum update "ovirt-*-setup*"` with a YUM dependency problem:



$ yum update "ovirt-*-setup*"
[...]
ovirt-engine-setup-plugin-ovirt-engine conflicts with ovirt-engine-4.1.3.5-1.el7.centos.noarch
[...]
$

For the complete yum update output see below.

I also noticed, that after having installed ovirt-release42, the old oVirt 4.1 repos were still present on the system. I disabled them manually to no avail.

`yum update ovirt-engine` results in "No packages marked for update".


Does anyone know, how we can fix this problem?

Cheers
frank

----- complete yum update output -----
$ yum update "ovirt-*-setup*"
Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
 * base: centos.alpha-labs.net
 * extras: centos.mirror.iphh.net
 * ovirt-4.2: ftp.nluug.nl
 * ovirt-4.2-epel: epel.besthosting.ua
 * updates: centos.mirror.iphh.net
Resolving Dependencies
--> Running transaction check
---> Package ovirt-engine-dwh-setup.noarch 0:4.1.9-1.el7.centos will be updated ---> Package ovirt-engine-dwh-setup.noarch 0:4.2.1-1.el7.centos will be an update --> Processing Dependency: rh-postgresql95-postgresql-server for package: ovirt-engine-dwh-setup-4.2.1-1.el7.centos.noarch ---> Package ovirt-engine-setup.noarch 0:4.1.9.1-1.el7.centos will be updated ---> Package ovirt-engine-setup.noarch 0:4.2.0.2-1.el7.centos will be an update ---> Package ovirt-engine-setup-base.noarch 0:4.1.9.1-1.el7.centos will be updated ---> Package ovirt-engine-setup-base.noarch 0:4.2.0.2-1.el7.centos will be an update --> Processing Dependency: otopi >= 1.7.1 for package: ovirt-engine-setup-base-4.2.0.2-1.el7.centos.noarch --> Processing Dependency: ovirt-engine-lib >= 4.2.0.2-1.el7.centos for package: ovirt-engine-setup-base-4.2.0.2-1.el7.centos.noarch ---> Package ovirt-engine-setup-plugin-ovirt-engine.noarch 0:4.1.9.1-1.el7.centos will be updated ---> Package ovirt-engine-setup-plugin-ovirt-engine.noarch 0:4.2.0.2-1.el7.centos will be an update --> Processing Dependency: openvswitch-ovn-central >= 2.7 for package: ovirt-engine-setup-plugin-ovirt-engine-4.2.0.2-1.el7.centos.noarch --> Processing Dependency: ovirt-provider-ovn for package: ovirt-engine-setup-plugin-ovirt-engine-4.2.0.2-1.el7.centos.noarch ---> Package ovirt-engine-setup-plugin-ovirt-engine-common.noarch 0:4.1.9.1-1.el7.centos will be updated ---> Package ovirt-engine-setup-plugin-ovirt-engine-common.noarch 0:4.2.0.2-1.el7.centos will be an update ---> Package ovirt-engine-setup-plugin-vmconsole-proxy-helper.noarch 0:4.1.9.1-1.el7.centos will be updated ---> Package ovirt-engine-setup-plugin-vmconsole-proxy-helper.noarch 0:4.2.0.2-1.el7.centos will be an update ---> Package ovirt-engine-setup-plugin-websocket-proxy.noarch 0:4.1.9.1-1.el7.centos will be updated ---> Package ovirt-engine-setup-plugin-websocket-proxy.noarch 0:4.2.0.2-1.el7.centos will be an update ---> Package ovirt-imageio-proxy-setup.noarch 0:1.0.0-0.201701151456.git89ae3b4.el7.centos will be updated ---> Package ovirt-imageio-proxy-setup.noarch 0:1.2.0-1.el7.centos will be an update
--> Running transaction check
---> Package openvswitch-ovn-central.x86_64 1:2.7.3-1.1fc27.el7 will be installed --> Processing Dependency: openvswitch-ovn-common for package: 1:openvswitch-ovn-central-2.7.3-1.1fc27.el7.x86_64 --> Processing Dependency: openvswitch for package: 1:openvswitch-ovn-central-2.7.3-1.1fc27.el7.x86_64
---> Package otopi.noarch 0:1.6.3-1.el7.centos will be updated
--> Processing Dependency: otopi = 1.6.3-1.el7.centos for package: otopi-java-1.6.3-1.el7.centos.noarch
---> Package otopi.noarch 0:1.7.5-1.el7.centos will be an update
---> Package ovirt-engine-lib.noarch 0:4.1.9.1-1.el7.centos will be updated
---> Package ovirt-engine-lib.noarch 0:4.2.0.2-1.el7.centos will be an update ---> Package ovirt-provider-ovn.noarch 0:1.2.2-1.el7.centos will be installed --> Processing Dependency: python-openvswitch >= 2.7 for package: ovirt-provider-ovn-1.2.2-1.el7.centos.noarch --> Processing Dependency: python2-ovsdbapp for package: ovirt-provider-ovn-1.2.2-1.el7.centos.noarch ---> Package rh-postgresql95-postgresql-server.x86_64 0:9.5.9-1.el7 will be installed --> Processing Dependency: rh-postgresql95-postgresql-libs(x86-64) = 9.5.9-1.el7 for package: rh-postgresql95-postgresql-server-9.5.9-1.el7.x86_64 --> Processing Dependency: rh-postgresql95-postgresql(x86-64) = 9.5.9-1.el7 for package: rh-postgresql95-postgresql-server-9.5.9-1.el7.x86_64 --> Processing Dependency: rh-postgresql95-runtime for package: rh-postgresql95-postgresql-server-9.5.9-1.el7.x86_64 --> Processing Dependency: /usr/bin/scl_source for package: rh-postgresql95-postgresql-server-9.5.9-1.el7.x86_64 --> Processing Dependency: libpq.so.rh-postgresql95-5()(64bit) for package: rh-postgresql95-postgresql-server-9.5.9-1.el7.x86_64
--> Running transaction check
---> Package openvswitch.x86_64 1:2.7.3-1.1fc27.el7 will be installed
---> Package openvswitch-ovn-common.x86_64 1:2.7.3-1.1fc27.el7 will be installed
---> Package otopi-java.noarch 0:1.6.3-1.el7.centos will be updated
---> Package otopi-java.noarch 0:1.7.5-1.el7.centos will be an update
---> Package python2-openvswitch.noarch 1:2.7.3-1.1fc27.el7 will be installed
---> Package python2-ovsdbapp.noarch 0:0.6.0-1.el7 will be installed
--> Processing Dependency: python-pbr >= 2.0.0 for package: python2-ovsdbapp-0.6.0-1.el7.noarch --> Processing Dependency: python-netaddr for package: python2-ovsdbapp-0.6.0-1.el7.noarch --> Processing Dependency: python-fixtures for package: python2-ovsdbapp-0.6.0-1.el7.noarch ---> Package rh-postgresql95-postgresql.x86_64 0:9.5.9-1.el7 will be installed ---> Package rh-postgresql95-postgresql-libs.x86_64 0:9.5.9-1.el7 will be installed
---> Package rh-postgresql95-runtime.x86_64 0:2.2-2.el7 will be installed
---> Package scl-utils.x86_64 0:20130529-18.el7_4 will be installed
--> Running transaction check
---> Package python-fixtures.noarch 0:3.0.0-2.el7 will be installed
--> Processing Dependency: python-testtools >= 0.9.22 for package: python-fixtures-3.0.0-2.el7.noarch
---> Package python-netaddr.noarch 0:0.7.5-7.el7 will be installed
---> Package python2-pbr.noarch 0:3.1.1-1.el7 will be installed
--> Running transaction check
---> Package python-testtools.noarch 0:1.8.0-2.el7 will be installed
--> Processing Dependency: python-unittest2 >= 0.8.0 for package: python-testtools-1.8.0-2.el7.noarch --> Processing Dependency: python-mimeparse for package: python-testtools-1.8.0-2.el7.noarch --> Processing Dependency: python-extras for package: python-testtools-1.8.0-2.el7.noarch
--> Running transaction check
---> Package python-extras.noarch 0:0.0.3-2.el7 will be installed
---> Package python-mimeparse.noarch 0:0.1.4-1.el7 will be installed
---> Package python-unittest2.noarch 0:1.0.1-1.el7 will be installed
--> Processing Dependency: python-traceback2 for package: python-unittest2-1.0.1-1.el7.noarch
--> Running transaction check
---> Package python-traceback2.noarch 0:1.4.0-2.el7 will be installed
--> Processing Dependency: python-linecache2 for package: python-traceback2-1.4.0-2.el7.noarch
--> Running transaction check
---> Package python-linecache2.noarch 0:1.0.0-1.el7 will be installed
--> Processing Conflict: ovirt-engine-setup-plugin-ovirt-engine-4.2.0.2-1.el7.centos.noarch conflicts ovirt-engine < 4.1.7
--> Finished Dependency Resolution
Error: ovirt-engine-setup-plugin-ovirt-engine conflicts with ovirt-engine-4.1.3.5-1.el7.centos.noarch
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
$

_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to