On Fri, Feb 2, 2018 at 1:04 PM, Andy <farkey_2...@yahoo.com> wrote:

> Simone,
>
> thanks for the help.  Attached at the rquested logs.  One thing to note I
> have three networks, one for gluster, migration, and storage (201, 200, and
> 199).
>
> thanks
>


host-deploy failed for this:

2018-01-31 00:52:48,803-0500 DEBUG otopi.plugins.otopi.dialog.machine
dialog.__logString:204 DIALOG:SEND       **%EventEnd STAGE setup METHOD
otopi.plugins.otopi.packagers.dnfpackager.Plugin._setup (None)
2018-01-31 00:52:48,805-0500 DEBUG otopi.context context._executeMethod:128
Stage setup METHOD otopi.plugins.otopi.packagers.yumpackager.Plugin._setup
2018-01-31 00:52:48,805-0500 DEBUG otopi.plugins.otopi.dialog.machine
dialog.__logString:204 DIALOG:SEND       **%EventStart STAGE setup METHOD
otopi.plugins.otopi.packagers.yumpackager.Plugin._setup (None)
2018-01-31 00:52:48,810-0500 DEBUG otopi.context context._executeMethod:143
method exception
Traceback (most recent call last):
  File "/tmp/ovirt-yTGUAVifQ3/pythonlib/otopi/context.py", line 133, in
_executeMethod
    method['method']()
  File
"/tmp/ovirt-yTGUAVifQ3/otopi-plugins/otopi/packagers/yumpackager.py", line
219, in _setup
    with self._miniyum.transaction():
  File "/tmp/ovirt-yTGUAVifQ3/pythonlib/otopi/miniyum.py", line 336, in
__enter__
    self._managed.beginTransaction()
  File "/tmp/ovirt-yTGUAVifQ3/pythonlib/otopi/miniyum.py", line 720, in
beginTransaction
    self._yb.doLock()
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2234, in
doLock
    raise Errors.LockError(0, msg, oldpid)
LockError: Existing lock /var/run/yum.pid: another copy is running as pid
23746.
2018-01-31 00:52:48,817-0500 ERROR otopi.context context._executeMethod:152
Failed to execute stage 'Environment setup': Existing lock
/var/run/yum.pid: another copy is running as pid 23746.

I'd suggest to check what is holding yum lock and simply retry.



>
>
> On Friday, February 2, 2018, 4:06:11 AM EST, Simone Tiraboschi <
> stira...@redhat.com> wrote:
>
>
> Hi Andy,
> can you please attach engine.log and host-deploy logs from the engine VM?
>
> On Fri, Feb 2, 2018 at 2:31 AM, Andy <farkey_2...@yahoo.com> wrote:
>
> Support,
>
> I am having a problem with redeploying the hosted engine to the second and
> third host in the cluster.  This setup is from a clean install of 4.2 and
> all the hosts are up and functional in the engine.  When I try to deploy
> the engine the install fails.
>
> Checking the VDSM service I get: vdsm[4752]: WARN Worker blocked: <Worker
> name=periodic/3 running <Task <Operation action=<vdsm.virt.sampling.
> HostMonitor object at 0x2807550> at 0x2807590> timeout=15, duration=270 at
> 0x1e0bc90> task#=186 at 0x27f0590>
>
> The setup is a three host ovirt 4.2 running CentOS 7.4, with three gluster
> volumes (engine and two data).  I have attached the agent, broker, ovirt
> setup, and vdsm logs.
>
> Any help is appreciated.
>
> Thanks
>
> ______________________________ _________________
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/ mailman/listinfo/users
> <http://lists.ovirt.org/mailman/listinfo/users>
>
>
>
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to