I had these types of issues as well my first time around, and after a
failed engine install I haven't been able to get things cleaned up, so I
will have to start over. I created a bonded interface on the host before
the engine setup. but once I created my first VM and assigned bond0 to it,
the engine became inaccessible the moment the VM got an IP from the
router.

What is the preferred way to setup bonded interfaces?  In Cockpit or nmcli
before hosted engine setup?  Or proceed with only one interface then add
the other in engine?

Is it possible, for example, to setup bonded interfaces with a static
management IP on vlan 50 to access the engine, and let the other VMs grab
DHCP IPs on vlan 10?


On Feb 3, 2018 11:31 PM, "Edward Haas" <eh...@redhat.com> wrote:



On Sat, Feb 3, 2018 at 9:06 AM, maoz zadok <mao...@gmail.com> wrote:

> Hello All,
> I'm new to oVirt, I'm trying with no success to set up the networking on
> an oVirt 4.2.0 node, and I think I'm missing something.
>
> background:
> interfaces em1-4 is bonded to bond0
> VLAN configured on bond0.1
> and bridged to ovirtmgmt for the management interface.
>
> I'm not sure its updated to version 4.2.0 but I followed this post:
> https://www.ovirt.org/documentation/how-to/networking/bonding-vlan-bridge/
>

It looks like an old howto, we will need to update or remove it.


>
> with this setting, the NetworkManager keep starting up on reboot,
> and the interfaces are not managed by oVirt (and the nice traffic graphs
> are not shown).
>

For the interfaces to be owned by oVirt, you will need to add the host to
Engine.
So I would just configure everything up to the VLAN (slaves, bond, VLAN)
with NetworkManager prior to adding it to Engine. The bridge should be
created when you add the host.
(assuming the VLAN you mentioned is your management interface and its ip is
the one used by Engine)


>
>
>
>
> my question:
> Is  NetworkManager need to be disabled as in the above post?
>

No (for 4.1 and 4.2)

Do I need to manage the networking using (nmtui) NetworkManager?
>

You better use cockpit or nmcli to configure the node before you add it to
Engine.


>
> Thanks!
> Maoz
>
>
>
>
>
> _______________________________________________
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
>

_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to