On 2-3-2018 11:25, geom...@mairie-saint-ouen.fr wrote:
>
> Hello,
>
>  
>
> I am on CENTOS 7.4.1708
>
>  
>
> I follow the documentation:
>
> [root@srvvm42 ~]# yum install ovirt-hosted-engine-setup
>
> [root@srvvm42 ~]# yum info ovirt-hosted-engine-setup
> Loaded plugins: fastestmirror, package_upload, product-id,
> search-disabled-repos, subscription-manager
> This system is not registered with an entitlement server. You can use
> subscription-manager to register.
> Loading mirror speeds from cached hostfile
>  * base: centos.quelquesmots.fr
>  * epel: mirrors.ircam.fr
>  * extras: centos.mirrors.ovh.net
>  * ovirt-4.2: ftp.nluug.nl
>  * ovirt-4.2-epel: mirrors.ircam.fr
>  * updates: centos.mirrors.ovh.net
> Installed Packages
> Name        : ovirt-hosted-engine-setup
> Arch        : noarch
> Version     : 2.2.9
> Release     : 1.el7.centos
> Size        : 2.3 M
> Repo        : installed
> From repo   : ovirt-4.2
> Summary     : oVirt Hosted Engine setup tool
> URL         : http://www.ovirt.org
> License     : LGPLv2+
> Description : Hosted Engine setup tool for oVirt project.
>
>
> [root@srvvm42 ~]# hosted-engine --deploy
>
> I encounter an issue when i try to install my hosted-engine. Here is
> the last line of the installation:
>
> ....
>
> [ INFO  ] TASK [Clean /etc/hosts for the engine VM]
> [ INFO  ] skipping: [localhost]
> [ INFO  ] TASK [Copy /etc/hosts back to the engine VM]
> [ INFO  ] skipping: [localhost]
> [ INFO  ] TASK [Clean /etc/hosts on the host]
> [ INFO  ] changed: [localhost]
> [ INFO  ] TASK [Add an entry in /etc/hosts for the target VM]
> [ INFO  ] changed: [localhost]
> [ INFO  ] TASK [Start broker]
> [ INFO  ] changed: [localhost]
> [ INFO  ] TASK [Initialize lockspace volume]
> [ INFO  ] changed: [localhost]
> [ INFO  ] TASK [Start agent]
> [ INFO  ] changed: [localhost]
> [ INFO  ] TASK [Wait for the engine to come up on the target VM]
> [ ERROR ] fatal: [localhost]: FAILED! => {"msg": "The conditional
> check 'health_result.rc == 0 and
> health_result.stdout|from_json|json_query('*.\"engine-status\".\"health\"')|first==\"good\"'
> failed. The error was: error while evaluating conditional
> (health_result.rc == 0 and
> health_result.stdout|from_json|json_query('*.\"engine-status\".\"health\"')|first==\"good\"):
> No first item, sequence was empty."}
> [ ERROR ] Failed to execute stage 'Closing up': Failed executing
> ansible-playbook
>
Guessing that it might be a firewall problem. Check what ports are open
after this fails. You can check it too, when the Engine is up you can
try to curl to your engine and see if it is reachable on 443, if not
then the healthcheck will fail.

Regards,

Joop

_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to