Hi,

I have an issue with Hosted Engine when I try to deploy via gui on another
host. There is no errors after deploy but in GUI I see only "Not active"
status HE, and hosted-engine --status shows only 1 node (on both nodes same
output). In hosted-engine.conf I see that host_id is the same as it is on
primary host with HE !? Issue looks quite similar like in

http://lists.ovirt.org/pipermail/users/2018-February/086932.html

Here is config file on newly deployed node :

ca_cert=/etc/pki/vdsm/libvirt-spice/ca-cert.pem
gateway=192.168.8.1
iqn=
conf_image_UUID=f2813205-4b0c-45f3-a9cb-3748f61d2194
ca_cert=/etc/pki/vdsm/libvirt-spice/ca-cert.pem
sdUUID=7e7a275c-6939-4f79-85f6-d695209951ea
connectionUUID=81a2f9a3-2efe-448f-b305-e22543068044
conf_volume_UUID=d6b7e25c-9912-47ff-b104-9d424b9f34b8
user=
host_id=1
bridge=ovirtmgmt
metadata_image_UUID=fe95f22e-b468-4adf-a754-21d419ae3e67
spUUID=00000000-0000-0000-0000-000000000000
mnt_options=
fqdn=dev-ovirtengine0.somedomain.it
portal=
vm_disk_id=febde231-92cc-4599-8f55-816f63132739
metadata_volume_UUID=7ebaf268-15ec-4c76-ba89-b5e2dc143830
vm_disk_vol_id=e3920b18-4467-44f8-b2d0-629b3b1d1a58
domainType=fc
port=
console=vnc
ca_subject="C=EN, L=Test, O=Test, CN=Test"
password=
vmid=3f7d9c1d-6c3e-4b96-b85d-d240f3bf9b76
lockspace_image_UUID=49e318ad-63a3-4efd-977c-33b8c4c93728
lockspace_volume_UUID=91bcb5cf-006c-42b4-b419-6ac9f841f50a
vdsm_use_ssl=true
storage=None
conf=/var/run/ovirt-hosted-engine-ha/vm.conf

This is original one:

fqdn=dev-ovirtengine0.somedomain.it
vm_disk_id=febde231-92cc-4599-8f55-816f63132739
vm_disk_vol_id=e3920b18-4467-44f8-b2d0-629b3b1d1a58
vmid=3f7d9c1d-6c3e-4b96-b85d-d240f3bf9b76
storage=None
mnt_options=
conf=/var/run/ovirt-hosted-engine-ha/vm.conf
host_id=1
console=vnc
domainType=fc
spUUID=00000000-0000-0000-0000-000000000000
sdUUID=7e7a275c-6939-4f79-85f6-d695209951ea
connectionUUID=81a2f9a3-2efe-448f-b305-e22543068044
ca_cert=/etc/pki/vdsm/libvirt-spice/ca-cert.pem
ca_subject="C=EN, L=Test, O=Test, CN=Test"
vdsm_use_ssl=true
gateway=192.168.8.1
bridge=ovirtmgmt
metadata_volume_UUID=7ebaf268-15ec-4c76-ba89-b5e2dc143830
metadata_image_UUID=fe95f22e-b468-4adf-a754-21d419ae3e67
lockspace_volume_UUID=91bcb5cf-006c-42b4-b419-6ac9f841f50a
lockspace_image_UUID=49e318ad-63a3-4efd-977c-33b8c4c93728
conf_volume_UUID=d6b7e25c-9912-47ff-b104-9d424b9f34b8
conf_image_UUID=f2813205-4b0c-45f3-a9cb-3748f61d2194

# The following are used only for iSCSI storage
iqn=
portal=
user=
password=
port=

Packages:

ovirt-imageio-daemon-1.0.0-1.el7.noarch
ovirt-host-deploy-1.6.7-1.el7.centos.noarch
ovirt-release41-4.1.9-1.el7.centos.noarch
ovirt-setup-lib-1.1.4-1.el7.centos.noarch
ovirt-hosted-engine-ha-2.1.8-1.el7.centos.noarch
ovirt-hosted-engine-setup-2.1.4-1.el7.centos.noarch
ovirt-vmconsole-1.0.4-1.el7.centos.noarch
ovirt-vmconsole-host-1.0.4-1.el7.centos.noarch
ovirt-engine-sdk-python-3.6.9.1-1.el7.centos.noarch
ovirt-imageio-common-1.0.0-1.el7.noarch

Output from agent.log

MainThread::INFO::2018-03-02
15:01:47,279::brokerlink::141::ovirt_hosted_engine_ha.lib.brokerlink.BrokerLink::(start_monitor)
Success, id 140493346760912
MainThread::INFO::2018-03-02
15:01:51,011::brokerlink::179::ovirt_hosted_engine_ha.lib.brokerlink.BrokerLink::(set_storage_domain)
Success, id 140493346759824
MainThread::INFO::2018-03-02
15:01:51,011::hosted_engine::601::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(_initialize_broker)
Broker initialized, all submonitors started
MainThread::INFO::2018-03-02
15:01:51,045::hosted_engine::704::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(_initialize_sanlock)
Ensuring lease for lockspace hosted-engine, host id 1 is acquired (file:
/var/run/vdsm/storage/7e7a275c-6939-4f79-85f6-d695209951ea/49e318ad-63a3-4efd-977c-33b8c4c93728/91bcb5cf-006c-42b4-b419-6ac9f841f50a)
MainThread::INFO::2018-03-02
15:04:12,058::hosted_engine::745::ovirt_hosted_engine_ha.agent.hosted_engine.HostedEngine::(_initialize_sanlock)
Failed to acquire the lock. Waiting '5's before the next attempt

Regards

Krzysztof
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to