a few days ago I installed an ovirt-engine following the steps of the 
documentation. After the installation I logged in to the admin page, configured 
a datadomain and changed the admin password. After a few hours I tried to login 
again, using the new password and got "Unable to log in because the user 
account is disabled or locked. Contact the system administrator." So I unlocked 
the admin account from the shell using "ovirt-aaa-jdbc-tool user unlock admin" 
which worked fine and I was able to continue working till the next login.

I traced the /var/log/ovirt-engine/engine.log and found this after unlocking 
the admin account again.

2018-04-12 09:06:19,984+02 INFO  
(EE-ManagedThreadFactory-engineScheduled-Thread-87) [2ed5aa42] Lock Acquired to 
2018-04-12 09:06:19,991+02 INFO  
(EE-ManagedThreadFactory-engineScheduled-Thread-87) [2ed5aa42] Running command: 
SyncNetworkProviderCommand internal: true.
2018-04-12 09:06:20,102+02 INFO  
[org.ovirt.engine.extension.aaa.jdbc.core.Authentication] (default task-239) [] 
locking user: admin due to interval failures
2018-04-12 09:06:25,046+02 ERROR [org.ovirt.engine.core.sso.utils.SsoUtils] 
(default task-239) [] OAuthException access_denied: Cannot authenticate user 
'admin@internal': The username or password is incorrect..
2018-04-12 09:06:25,049+02 ERROR 
(EE-ManagedThreadFactory-engineScheduled-Thread-87) [2ed5aa42] Command 
'org.ovirt.engine.core.bll.provider.network.SyncNetworkProviderCommand' failed: 
EngineException: (Failed with error Unauthorized and code 5050)
2018-04-12 09:06:25,050+02 INFO  
(EE-ManagedThreadFactory-engineScheduled-Thread-87) [2ed5aa42] Lock freed to 

It seems like the SyncNetworkProviderCommand is somehow locking the admin 
account. I already restarted the whole machine but it didn't help.

Can someone please point me in the right direction, where to find the error?

Thanks in advance
Users mailing list

Reply via email to