Hi,
Could someone please provide advice on a production oVirt instance that fails 
to upgrade to 4.2.3?

Engine and hosts are all running CentOS 7

As per the upgrade instructions in the release notes I run:
# yum install http://resources.ovirt.org/pub/yum-repo/ovirt-release42.rpm
# yum update "ovirt-*-setup*"
# engine-setup

Then I answer the questions and it fails with:
...
[ INFO  ] Upgrading PostgreSQL
[ ERROR ] Failed to execute stage 'Misc configuration': Command 
'/opt/rh/rh-postgresql95/root/usr/bin/postgresql-setup' failed to execute
[ INFO  ] Yum Performing yum transaction rollback
[ INFO  ] Rolling back to the previous PostgreSQL instance (postgresql).
[ INFO  ] Stage: Clean up
          Log file is located at 
/var/log/ovirt-engine/setup/ovirt-engine-setup-20180516231622-3giicb.log
[ INFO  ] Generating answer file 
'/var/lib/ovirt-engine/setup/answers/20180516231735-setup.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed


When I check  /var/lib/pgsql/upgrade_rh-postgresql95-postgresql.log:

Performing Consistency Checks
-----------------------------
Checking cluster versions                                   ok
Checking database user is the install user                  ok
Checking database connection settings                       ok
Checking for prepared transactions                          ok
Checking for reg* system OID user data types                ok
Checking for contrib/isn with bigint-passing mismatch       ok
Checking for invalid "line" user columns                    ok
Creating dump of global objects                             ok
Creating dump of database schemas
  engine
  ovirt_engine_history
  postgres
  template1
                                                            ok

lc_collate values for database "postgres" do not match:  old "en_GB.UTF-8", new 
"en_US.UTF-8"
Failure, exiting


I have tried running the script here: 
https://gist.github.com/turboladen/6790847 and rerunning engine-setup but it 
fails with the same error.

Can anyone offer any other suggestions?

Best regards

Ian Fraser

Systems Administrator | Agency Sector Management (UK) Limited | www.asm.org.uk
[t] +44 (0)1784 242200 | [f] +44 (0)1784 242012 | [e] ian.fra...@asm.org.uk
Registered in England No. 2053849 | Registered address: Ashford House  41-45 
Church Road  Ashford  Middx  TW15 2TQ
Follow us on twitter @asmukltd<https://twitter.com/asmukltd>

_______________________________________________
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org

Reply via email to