Hi!

I'm having trouble installing the oVirt Metrics Store following this 
https://www.ovirt.org/develop/release-management/features/metrics/metrics-store-installation/
 respectively this guide 
https://www.ovirt.org/develop/release-management/features/metrics/setting-up-viaq-logging/

When executing the test script
ANSIBLE_LOG_PATH=/tmp/ansible-prereq.log ansible-playbook -vvv -e 
@/root/vars.yaml -i /root/ansible-inventory-origin-39-aio 
playbooks/prerequisites.yml

following error occurs:


Using module file 
/usr/lib/python2.7/site-packages/ansible/modules/packaging/os/yum.py
<localhost> EXEC /bin/sh -c '/usr/bin/python && sleep 0'
fatal: [localhost]: FAILED! => {
    "attempts": 3,
    "changed": false,
    "invocation": {
        "module_args": {
            "allow_downgrade": false,
            "bugfix": false,
            "conf_file": null,
            "disable_gpg_check": false,
            "disable_plugin": [],
            "disablerepo": null,
            "enable_plugin": [],
            "enablerepo": null,
            "exclude": null,
            "install_repoquery": true,
            "installroot": "/",
            "list": null,
            "name": [
                "docker",
                "atomic",
                "skopeo"
            ],
            "security": false,
            "skip_broken": false,
            "state": "present",
            "update_cache": false,
            "update_only": false,
            "validate_certs": true
        }
    },
    "msg": "Error: Package: 1:atomic-1.22.1-22.git5a342e3.el7.x86_64 
(centosplus)\n           Requires: python-docker-py >= 1.7.2-1\n           
Available: docker-python-1.4.0-115.el7.x86_64 (centosplus)\n               
python-docker-py = 1.4.0-115.el7\n           Available: 
python-docker-py-1.10.6-3.el7.noarch (centosplus)\n               
python-docker-py = 1.10.6-3.el7\n           Available: 
python-docker-py-1.10.6-4.el7.noarch (centosplus)\n               
python-docker-py = 1.10.6-4.el7\n           Available: 
python2-docker-2.4.2-1.2.el7.noarch (centos-openshift-origin-testing-cbs)\n     
          python-docker-py = 2.4.2-1.2.el7\n           Installed: 
python2-docker-3.3.0-1.el7.noarch (@centos-openshift-origin-testing)\n          
     Not found\n",
    "rc": 1,
    "results": [
        "2:docker-1.13.1-74.git6e3bb8e.el7.centos.x86_64 providing docker is 
already installed",
        "Loaded plugins: fastestmirror\nLoading mirror speeds from cached 
hostfile\nResolving Dependencies\n--> Running transaction check\n---> Package 
atomic.x86_64 1:1.22.1-22.git5a342e3.el7 will be installed\n--> Processing 
Dependency: python-docker-py >= 1.7.2-1 for package: 
1:atomic-1.22.1-22.git5a342e3.el7.x86_64\nPackage 
python-docker-py-1.10.6-4.el7.noarch is obsoleted by 
python2-docker-3.3.0-1.el7.noarch which is already installed\n--> Processing 
Dependency: runc for package: 1:atomic-1.22.1-22.git5a342e3.el7.x86_64\n--> 
Processing Dependency: python-dateutil for package: 
1:atomic-1.22.1-22.git5a342e3.el7.x86_64\n--> Processing Dependency: ostree for 
package: 1:atomic-1.22.1-22.git5a342e3.el7.x86_64\n--> Processing Dependency: 
gomtree for package: 1:atomic-1.22.1-22.git5a342e3.el7.x86_64\n---> Package 
skopeo.x86_64 1:0.1.31-1.dev.gitae64ff7.el7.centos will be installed\n--> 
Running transaction check\n---> Package atomic.x86_64 
1:1.22.1-22.git5a342e3.el7 will be installed\n--
 > Processing Dependency: python-docker-py >= 1.7.2-1 for package: 
 > 1:atomic-1.22.1-22.git5a342e3.el7.x86_64\nPackage 
 > python-docker-py-1.10.6-4.el7.noarch is obsoleted by 
 > python2-docker-3.3.0-1.el7.noarch which is already installed\n---> Package 
 > gomtree.x86_64 0:0.5.0-0.2.git16da0f8.el7 will be installed\n---> Package 
 > ostree.x86_64 0:2018.5-1.el7 will be installed\n--> Processing Dependency: 
 > libarchive.so.13()(64bit) for package: ostree-2018.5-1.el7.x86_64\n---> 
 > Package python-dateutil.noarch 0:1.5-7.el7 will be installed\n---> Package 
 > runc.x86_64 0:1.0.0-37.rc5.dev.gitad0f525.el7 will be installed\n--> 
 > Processing Dependency: criu for package: 
 > runc-1.0.0-37.rc5.dev.gitad0f525.el7.x86_64\n--> Running transaction 
 > check\n---> Package atomic.x86_64 1:1.22.1-22.git5a342e3.el7 will be 
 > installed\n--> Processing Dependency: python-docker-py >= 1.7.2-1 for 
 > package: 1:atomic-1.22.1-22.git5a342e3.el7.x86_64\nPackage 
 > python-docker-py-1.10.6-4.el7.noarch is obsoleted by 
 > python2-docker-3.3.0-1.el7.
 noarch which is already installed\n---> Package criu.x86_64 0:3.5-4.el7 will 
be installed\n--> Processing Dependency: 
libprotobuf-c.so.1(LIBPROTOBUF_C_1.0.0)(64bit) for package: 
criu-3.5-4.el7.x86_64\n--> Processing Dependency: libprotobuf-c.so.1()(64bit) 
for package: criu-3.5-4.el7.x86_64\n--> Processing Dependency: 
libnet.so.1()(64bit) for package: criu-3.5-4.el7.x86_64\n---> Package 
libarchive.x86_64 0:3.1.2-10.el7_2 will be installed\n--> Running transaction 
check\n---> Package atomic.x86_64 1:1.22.1-22.git5a342e3.el7 will be 
installed\n--> Processing Dependency: python-docker-py >= 1.7.2-1 for package: 
1:atomic-1.22.1-22.git5a342e3.el7.x86_64\nPackage 
python-docker-py-1.10.6-4.el7.noarch is obsoleted by 
python2-docker-3.3.0-1.el7.noarch which is already installed\n---> Package 
libnet.x86_64 0:1.1.6-7.el7 will be installed\n---> Package protobuf-c.x86_64 
0:1.0.2-3.el7 will be installed\n--> Finished Dependency Resolution\n You could 
try using --skip-broken to work around the pro
 blem\n You could try running: rpm -Va --nofiles --nodigest\n"
    ]
}

PLAY RECAP 
************************************************************************************************************************************************************
localhost                  : ok=75   changed=6    unreachable=0    failed=1


I already already found out that there might be a bug in some older versions of 
openshift/ansible but the recent versions should be fine. 

Thanks for any suggestions on this!
_______________________________________________
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/site/privacy-policy/
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/MNL7FQNNLRTLJCNOEJAIIW6JK4GA6CPD/

Reply via email to