I deployed oVirt on three servers with Gluster storage: x8dt3-10, x8dt3-11, and x8dt3-12. Hosted-engine is deployed on the x8dt3-10 host. Created two volumes with 3 replicas each - one for the hosted-engine, and the second for the storage of the other VMS.
I ran into the following problem : I can't start any of the VMS on hosts x8dt3-11 and x8dt3-12, and the hosted-engine doesn't migrate to these hosts either. VMS start normally on the x8dt3-10 host.
After looking at the libvirt logs on hosts x8dt3-11, x8dt3-12, I saw the following problem:
2020-03-29T18:13:01.883013 Z qemu-kvm: - drive file=/rhev/data-center/mnt/glusterSD/x8dt3-10:_vmstore/123c435d-cd31-4120-8062-28d5ec08bef2/images/3b22c1f2-2173-4b18-9e3e-7eec39b2cb6b/443a07cd-6bef-4d5c-b90a-aa50811c5782,format=raw,if=none,id=drive-ua-3b22c1f2-2173-4b18-9e3e-7eec39b2cb6b,serial=3b22c1f2-2173-4b18-9e3e-7eec39b2cb6b,werror=stop,rerror=stop,cache=none,aio=threads: Could not open '/rhev/data-center/mnt/glusterSD/x8dt3-10:_vmstore/123c435d-cd31-4120-8062-28d5ec08bef2/images/3b22c1f2-2173-4b18-9e3e-7eec39b2cb6b/443a07cd-6bef-4d5c-b90a-aa50811c5782': Permission denied
Permissions for folders on the path to the VM disk on hosts x8dt3-11, x8dt3-12 are the same as on host x8dt3-10.
I tried changing the user and group to root in /etc/libvirt/qemu.conf. I disabled firewalld and SELinux - nothing helped.
How do I fix the problem?
With respect,
Vadim Simonenko
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
List Archives: 

Reply via email to