Hi,

Ovirt 4.3.9.4-1.el7, CentOS7...

colleague of me tried yesterday do a snapshot preview on his vm but
operation got stalled.

I can see in Task list in Manager operation "Preview VM Snapshot před AD
test of VM install_W10_LTSC-REK" in state Finalizing (6 hours ago)

In the Events I see

May 19, 2020, 4:00:17 PM
Failed to complete Snapshot-Preview před AD test for VM
install_W10_LTSC-REK.
18acb86e-581c-43f5-bf99-f8d738870976

May 19, 2020, 3:57:40 PM
Failed to run VM install_W10_LTSC-REK due to a failed validation:
[Cannot run VM. The VM is performing an operation on a Snapshot. Please
wait for the operation to finish, and try again.] (User: ******@*********).
d892b7dd-741b-4c61-ac37-b1077eaeaf79

When I grepping correlation id from failed run from engine log a got

zcat /var/log/ovirt-engine/engine.log-20200520.gz | grep
"d892b7dd-741b-4c61-ac37-b1077eaeaf79"

2020-05-19 15:57:40,435+02 INFO
[org.ovirt.engine.core.bll.RunVmCommand] (default task-210)
[d892b7dd-741b-4c61-ac37-b1077eaeaf79] Lock Acquired to object
'EngineLock:{exclusiveLocks='[2f1fb183-55ea-477c-a75b-625f889e4c79=VM]',
sharedLocks=''}'
2020-05-19 15:57:40,489+02 ERROR
[org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector]
(default task-210) [d892b7dd-741b-4c61-ac37-b1077eaeaf79] EVENT_ID:
USER_FAILED_RUN_VM(54), Failed to run VM install_W10_LTSC-REK due to a
failed validation: [Cannot run VM. The VM is performing an operation on
a Snapshot. Please wait for the operation to finish, and try again.]
(User: kra0...@cro.slu.cz).
2020-05-19 15:57:40,489+02 WARN
[org.ovirt.engine.core.bll.RunVmCommand] (default task-210)
[d892b7dd-741b-4c61-ac37-b1077eaeaf79] Validation of action 'RunVm'
failed for user kra0...@cro.slu.cz. Reasons:
VAR__ACTION__RUN,VAR__TYPE__VM,ACTION_TYPE_FAILED_VM_IS_DURING_SNAPSHOT
2020-05-19 15:57:40,489+02 INFO
[org.ovirt.engine.core.bll.RunVmCommand] (default task-210)
[d892b7dd-741b-4c61-ac37-b1077eaeaf79] Lock freed to object
'EngineLock:{exclusiveLocks='[2f1fb183-55ea-477c-a75b-625f889e4c79=VM]',
sharedLocks=''}'

greping correlation id on failed snapshot preview shows only INFO
events, not ERRORS nor WARNINGS and it looks to me like everything was
FINISHed

When I try to display locked entities a got

cd /usr/share/ovirt-engine/setup/dbutils
./unlock_entity.sh -q -t all -c

Locked VMs

       vm_name        |             snapshot_id
----------------------+--------------------------------------
 install_W10_LTSC-REK | 9d53c7b4-8ec5-4d31-8ab1-16bb75ab8f2b


Locked templates

 template_name | disk_id
---------------+---------


Locked disks

                vm_id                 |               disk_id

--------------------------------------+--------------------------------------
 2f1fb183-55ea-477c-a75b-625f889e4c79 | 707db1f6-0859-48ab-b9d0-a97619ed8b0b


Locked snapshots

                vm_id                 |             snapshot_id

--------------------------------------+--------------------------------------
 2f1fb183-55ea-477c-a75b-625f889e4c79 | 9d53c7b4-8ec5-4d31-8ab1-16bb75ab8f2b


Illegal images

 vm_name | image_guid
---------+------------

I am about to try unlock that snapshot but for sure...

* how can I be sure that snapshot operations is not still running (it
would be nice to have some sort of progress bar o better reporting what
is happening in Manager...)

* looks it like bug? Should I fill bugreport or publish more logs?

Cheers,

Jiri

Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

_______________________________________________
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/H5SSEVCCZU5WCCQJMB72P5H6K2ZYLCTP/

Reply via email to