Are you using ECC ram ?

Best Regards,
Strahil Nikolov

На 8 юни 2020 г. 15:06:22 GMT+03:00, Joop <jvdw...@xs4all.nl> написа:
>On 3-6-2020 14:58, Joop wrote:
>> Hi All,
>>
>> Just had a rather new experience in that starting a VM worked but the
>> kernel entered grub2 rescue console due to the fact that something
>was
>> wrong with its virtio-scsi disk.
>> The message is Booting from Hard Disk ....
>> error: ../../grub-core/kern/dl.c:266:invalid arch-independent ELF
>maginc.
>> entering rescue mode...
>>
>> Doing a CTRL-ALT-Del through the spice console let the VM boot
>> correctly. Shutting it down and repeating the procedure I get a disk
>> problem everytime. Weird thing is if I activate the BootMenu and then
>> straight away start the VM all is OK.
>> I don't see any ERROR messages in either vdsm.log, engine.log
>>
>> If I would have to guess it looks like the disk image isn't connected
>> yet when the VM boots but thats weird isn't it?
>>
>>
>As an update to this:
>Just had the same problem with a Windows VM but more importantly also
>with HostedEngine itself.
>On the host did:
>hosted-engine --set-maintenance --mode=global
>hosted-engine --vm-shutdown
>
>Stopped all oVirt related services, cleared all oVirt related logs from
>/var/log/..., restarted the host, ran hosted-engine --set-maintenance
>--mode=none
>Watched /var/spool/mail/root to see the engine coming up. It went to
>starting but never came into the Up status.
>Set a password and used vncviewer to see the console, see attached
>screenschot.
>hosted-engine --vm-poweroff, and tried again, same result
>hosted-engine --vm-start, works
>Let it startup and then shut it down after enabling maintenance mode.
>Copied, hopefully, all relevant logs and attached them.
>
>A sosreport is also available, size 12Mb. I can provide a download link
>if needed.
>
>Hopefully someone is able to spot what is going wrong.
>
>Regards,
>
>Joop
_______________________________________________
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/XASNIEZTZIMWAUIANSOPCX4ZBK6T7TZT/

Reply via email to