On 7/15/20 9:40 AM, Yedidyah Bar David wrote:
On Wed, Jul 15, 2020 at 8:14 AM AK via Users <users@ovirt.org> wrote:

Yes sir,  I run the clean up script after each failure, clean out the gluster 
volume, and remove any network the deploy scripts create.   I just conducted 
the deployment on different hardware (different drives, different CPU, raid 
controller, SSD's) and it produced the same result (failure at 
OVF_STore_check).  The only deployment items that are consistent are creating 
the physical network bonds and gluster volumes which can be mounted across the 
network and have been tested as storage pools for other virtualization and 
storage platforms.

Can you please check engine-side logs? If you can access the engine VM
(search hosted-engine logs for local_vm_ip if it's still on the local
network), check /var/log/ovirt-engine/*, otherwise, on the host,

That said, we also have (what seems like) a very similar failure on
CI, for some time now - check e.g. the latest nightly run:



2020-07-14 22:59:42,414-0400 INFO ansible task start {'status': 'OK',
'ansible_type': 'task', 'ansible_playbook':
'ansible_task': 'ovirt.hosted_engine_setup : Check OVF_STORE volume

It tries some time, eventually fails, like your case. engine log has:


2020-07-14 22:57:03,197-04 INFO
(default task-1) [4abbccc] EVENT_ID: USER_VDC_LOGOUT(31), User
admin@internal-authz connected from '' using session
logged out.
2020-07-14 22:57:03,242-04 ERROR
[313eed07] Command 'UploadStreamVDSCommand(HostName =
execution failed: javax.net.ssl.SSLPeerUnverifiedException:
Certificate for <lago-he-basic-suite-master-host-0.lago.local> doesn't
match any of the subject alternative names:

This is currently discussed on the devel list, in thread:

     execution failed: javax.net.ssl.SSLPeerUnverifiedException (was:
[ovirt-devel] vdsm.storage.exception.UnknownTask: Task id unknown
(was: [oVirt Jenkins] ovirt-system-tests_he-basic-suite-master - Build
# 1641 - Still Failing!))

We are still not sure about the exact cause, but I have a feeling that
it's somehow related to naming/name resolution/hostname/etc.

In any case, I didn't manage to reproduce this locally on my own machine.

I suggest checking everything you can think of related to this -
dhcp/dns, output of 'hostname' on the host, etc.

Good luck and best regards,

The javax.net.ssl.SSLPeerUnverifiedException may be caused by a recent regression in HttpClient:
This only affects domains which are not publicly accessible, e.g. .local or .test. According to the bug report it was fixed upstream.

Best regards,
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
List Archives: 

Reply via email to