Hi there. I'm trying to get oVirt up & running on a server in a network that 
has no access to the Internet. We do host mirrors of CentOS 7 & 8 repos (no 
Stream). I first tried the latest version of oVirt 4.4, however, I ran into an 
issue when trying to do the Hosted Engine deployment. The command I used was 
"hosted-engine --deploy --ansible-extra-vars=he_offline_deployment=true". But 
at some point, I get the following error:

[ INFO  ] DNF Errors during downloading metadata for repository 
           - Status code: 404 for 
[ ERROR ] DNF Failed to download metadata for repo 
'ovirt-4.4-centos-ceph-pacific': Cannot download repomd.xml: Cannot download 
repodata/repomd.xml: All mirrors were tried

Seems like it's still trying to download something from the CentOS 8 Stream 
repo. So I figured that since we have the CentOS 7 repos hosted, I'll try oVirt 
v4.3. However, I don't see an option to do an "offline deployment" with this 
version. It says the "--ansible-extra-vars" option is invalid. I tried doing a 
regular deployment but it tries downloading from the oVirt repo:

[ INFO ] TASK [ovirt.hosted_enging_setup : Install ovirt-engine-appliance rpm]
[ ERROR ] fatal: [localhost]: FAILED! => ["attempts": 10, "changed": false, 
"msg": "Failure talking to yum: cannot retrieve metalink for repository: 
ovirt-4.3-epel/x86_64. Please verify its path and try again"}

I can bring over a mirror of the ovirt-4.3 repo. I also see that there's some 
other repos in the "ovirt-4.3-dependencies.repo" file. Are those required for 
deploying the hosted engine VM as well? Or does anyone know if there's a way to 
do this deployment completely offline?

Thank you for your time.
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
List Archives: 

Reply via email to