Hi all,

In relation to a recent question here (thread "[ovirt-devel] [ANN]
Schedule for oVirt 4.5.0"), we are now blocked with the following
chain of changes/dependencies:

1. ovirt-ansible-collection recently moved from ansible-2.9 to
ansible-core 2.12.
2. ovirt-hosted-engine-setup followed it.
3. ovirt-release-host-node (the package including dependencies for
ovirt-node) requires gluster-ansible-roles.
4. gluster-ansible-roles right now requires 'ansible >= 2.9' (not
core), and I only checked one of its dependencies,
gluster-ansible-infra, and this one requires 'ansible >= 2.5'.
5. ansible-core does not 'Provide: ansible', IIUC intentionally.

So we should do one of:

1. Fix gluster-ansible* packages to work with ansible-core 2.12.

2. Only patch gluster-ansible* packages to require ansible-core,
without making sure they actually work with it. This will satisfy all
deps (I guess), make the thing installable, but will likely break when
actually used. Not sure it's such a good option, but nonetheless
relevant. Might make sense if someone is going to work on (1.) soon
but not immediately. This is what would have happened in practice, if
ansible-core would have 'Provide:'-ed ansible.

3. Patch ovirt-release-host-node to not require gluster-ansible*
anymore. This means it will not be included in ovirt-node. Users that
will want to use it will have to install the dependencies manually,
somehow, presumably after (1.) is done independently.

Our team (RHV integration) does not have capacity for (1.). I intend
to do (3.) very soon, unless we get volunteers for doing (1.) or
strong voices for (2.).

Best regards,
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
List Archives: 

Reply via email to