Dear Martin,

Not getting e-mails from ovirt list is my local issue. I will deal with this.

Async upgrade is OK. The update of Standalone engine/CentOS Stream release 8 
shows - Version 4.5.3.1-1.el8

When executing ‘dnf update’ on standalone engine – update fails - the result is 
below. Do you thing manual elimination of rdo-related will solve it?

Thank you!
Best,
Latcho


Last metadata expiration check: 3:56:58 ago on Fri 21 Oct 2022 06:47:31 AM EEST.
Error:
 Problem 1: package ovirt-engine-4.5.3.1-1.el8.noarch conflicts with 
ansible-core >= 2.13.0 provided by ansible-core-2.13.3-1.el8.x86_64
  - cannot install the best update candidate for package 
ovirt-engine-4.5.3.1-1.el8.noarch
  - cannot install the best update candidate for package 
ansible-core-2.12.7-1.el8.x86_64
Problem 2: package ovirt-openvswitch-2.15-4.el8.noarch requires 
openvswitch2.15, but none of the providers can be installed
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-119.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-106.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-110.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-115.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-117.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-22.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-23.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-24.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-27.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-30.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-32.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-35.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-37.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-39.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-41.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-47.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-48.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-51.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-52.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-53.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-54.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-56.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-6.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-72.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-75.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-80.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-81.el8s.x86_64
  - package rdo-openvswitch-2:2.17-3.el8.noarch obsoletes openvswitch2.15 < 
2.17 provided by openvswitch2.15-2.15.0-88.el8s.x86_64
  - cannot install the best update candidate for package 
ovirt-openvswitch-2.15-4.el8.noarch
  - cannot install the best update candidate for package 
openvswitch2.15-2.15.0-119.el8s.x86_64
Problem 3: package ovirt-openvswitch-ovn-common-2.15-4.el8.noarch requires 
ovn-2021, but none of the providers can be installed
  - package rdo-ovn-2:22.06-3.el8.noarch obsoletes ovn-2021 < 22.06 provided by 
ovn-2021-21.12.0-82.el8s.x86_64
  - package rdo-ovn-2:22.06-3.el8.noarch obsoletes ovn-2021 < 22.06 provided by 
ovn-2021-21.03.0-21.el8s.x86_64
  - package rdo-ovn-2:22.06-3.el8.noarch obsoletes ovn-2021 < 22.06 provided by 
ovn-2021-21.03.0-40.el8s.x86_64
  - package rdo-ovn-2:22.06-3.el8.noarch obsoletes ovn-2021 < 22.06 provided by 
ovn-2021-21.06.0-17.el8s.x86_64
  - package rdo-ovn-2:22.06-3.el8.noarch obsoletes ovn-2021 < 22.06 provided by 
ovn-2021-21.06.0-29.el8s.x86_64
  - package rdo-ovn-2:22.06-3.el8.noarch obsoletes ovn-2021 < 22.06 provided by 
ovn-2021-21.12.0-11.el8s.x86_64
  - cannot install the best update candidate for package 
ovn-2021-21.12.0-82.el8s.x86_64
  - cannot install the best update candidate for package 
ovirt-openvswitch-ovn-common-2.15-4.el8.noarch
Problem 4: package ovirt-openvswitch-ovn-central-2.15-4.el8.noarch requires 
ovn-2021-central, but none of the providers can be installed
  - package rdo-ovn-central-2:22.06-3.el8.noarch obsoletes ovn-2021-central < 
22.06 provided by ovn-2021-central-21.12.0-82.el8s.x86_64
  - package rdo-ovn-central-2:22.06-3.el8.noarch obsoletes ovn-2021-central < 
22.06 provided by ovn-2021-central-21.03.0-21.el8s.x86_64
  - package rdo-ovn-central-2:22.06-3.el8.noarch obsoletes ovn-2021-central < 
22.06 provided by ovn-2021-central-21.03.0-40.el8s.x86_64
  - package rdo-ovn-central-2:22.06-3.el8.noarch obsoletes ovn-2021-central < 
22.06 provided by ovn-2021-central-21.06.0-17.el8s.x86_64
  - package rdo-ovn-central-2:22.06-3.el8.noarch obsoletes ovn-2021-central < 
22.06 provided by ovn-2021-central-21.06.0-29.el8s.x86_64
  - package rdo-ovn-central-2:22.06-3.el8.noarch obsoletes ovn-2021-central < 
22.06 provided by ovn-2021-central-21.12.0-11.el8s.x86_64
  - cannot install the best update candidate for package 
ovn-2021-central-21.12.0-82.el8s.x86_64
  - cannot install the best update candidate for package 
ovirt-openvswitch-ovn-central-2.15-4.el8.noarch
Problem 5: package ovirt-python-openvswitch-2.15-4.el8.noarch requires 
python3-openvswitch2.15, but none of the providers can be installed
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-119.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-106.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-110.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-115.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-117.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-22.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-23.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-24.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-27.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-30.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-32.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-35.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-37.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-39.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-41.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-47.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-48.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-51.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-52.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-53.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-54.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-56.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-6.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-72.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-75.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-80.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-81.el8s.x86_64
  - package python3-rdo-openvswitch-2:2.17-3.el8.noarch obsoletes 
python3-openvswitch2.15 < 2.17 provided by 
python3-openvswitch2.15-2.15.0-88.el8s.x86_64
  - cannot install the best update candidate for package 
python3-openvswitch2.15-2.15.0-119.el8s.x86_64
  - cannot install the best update candidate for package 
ovirt-python-openvswitch-2.15-4.el8.noarch
(try to add '--allowerasing' to command line to replace conflicting packages or 
'--skip-broken' to skip uninstallable packages or '--nobest' to use not only 
best candidate packages)

From: Martin Perina <mper...@redhat.com>
Sent: Friday, October 21, 2022 10:13 AM
To: Latchezar Filtchev <lat...@aubg.bg>
Cc: David Johnson <djohn...@maxistechnology.com>; Milan Zamazal 
<mzama...@redhat.com>; users <users@ovirt.org>
Subject: Re: [ovirt-users] Re: RPM issues updating Ovirt 4.5.2 to 4.5.3

Hi Latchezar,

yesterday we have released an async oVirt 4.5.3.1 version, which is fixing this 
repository issue, so once you upgrade your ovirt-release45 package, you should 
no longer need to do any manual actions. More info in 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/LXCTQGKBF2UBENE2I27TVJSEZFNBUSGC/

Regards,
Martin


On Fri, Oct 21, 2022 at 9:02 AM Latchezar Filtchev 
<lat...@aubg.bg<mailto:lat...@aubg.bg>> wrote:
Dear David,

Can you point where is this official workaround? May be I am missing responses 
you are talking about.

Thank you!
Best,
Latcho


From: David Johnson 
<djohn...@maxistechnology.com<mailto:djohn...@maxistechnology.com>>
Sent: Wednesday, October 19, 2022 4:42 PM
To: Milan Zamazal <mzama...@redhat.com<mailto:mzama...@redhat.com>>
Cc: users <users@ovirt.org<mailto:users@ovirt.org>>
Subject: [ovirt-users] Re: RPM issues updating Ovirt 4.5.2 to 4.5.3

Thank you Milan,

This is also the official workaround, based on other responses.
_______________________________________________
Users mailing list -- users@ovirt.org<mailto:users@ovirt.org>
To unsubscribe send an email to 
users-le...@ovirt.org<mailto:users-le...@ovirt.org>
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/ADW64DEAZAKM3MH4GJ2DHPZ4BDPO2SSZ/


--
Martin Perina
Manager, Software Engineering
Red Hat Czech s.r.o.
_______________________________________________
Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/privacy-policy.html
oVirt Code of Conduct: 
https://www.ovirt.org/community/about/community-guidelines/
List Archives: 
https://lists.ovirt.org/archives/list/users@ovirt.org/message/MLCD6XIZDNPRBQGETO5AGWKFQAF2INY5/

Reply via email to