Thanks Bill..
i already did but still no clues...
Files in my Debian SA package (3.4.1) containing the string PYZOR_CHECK:
# for i in `dpkg -L spamassassin`; do grep -l PYZOR_CHECK $i 2>/dev/null ; 
done/usr/share/spamassassin/ contains:

 ifplugin Mail::SpamAssassin::Plugin::Pyzor full PYZOR_CHECK        
 describe PYZOR_CHECK    Listed in Pyzor ( tflags 
PYZOR_CHECK      net reuse  PYZOR_CHECK endif

and contains:
 ifplugin Mail::SpamAssassin::Plugin::Pyzor score PYZOR_CHECK 0 1.985 0 1.392 # 
n=0 n=2 endif # Mail::SpamAssassin::Plugin::Pyzor

i have even looked for the string PYZOR_CHECK throughout the full system... and 
no more files contain that string.
i have tried sa-compile of course but... is there maybe any cache i can delete 
manually? not to my knowledge but...

      From: Bill Cole <>
 To: SA Mailing List <> 
 Sent: Wednesday, October 19, 2016 6:04 AM
 Subject: Re: PYZOR_CHECK always have zero score, why?
On 18 Oct 2016, at 23:22, Pedro David Marco wrote:

> So Pyzor seems to be OK!... the problem is somehow related to 
> PYZOR_CHECK rule but why??? 

Some config file is being loaded that sets the score of PYZOR_CHECK to 
0. It is NOT 0 in the current default ruleset: PYZOR_CHECK 0 1.985 0 1.392 # n=0 n=2

Examine the unfiltered debug output for what config files are actually 
being loaded. My suspicion is that this is some Debian modification.


Reply via email to