Thanks for the help. I tried using apr-config and the configuration went
well, however, I got the following error doing the make check:

collect2: error: ld returned 1 exit status
build-outputs.mk:485: recipe for target 'subversion/libsvn_subr/
libsvn_subr-1.la' failed
make: *** [subversion/libsvn_subr/libsvn_subr-1.la] Error 1

What should I Do?

2018-03-07 2:19 GMT-06:00 David Chapman <dcchap...@acm.org>:

> On 3/6/2018 6:54 PM, Guido granda muñoz wrote:
>> Hello,
>> I'm trying to install subversion 1.9.7 in Ubuntu 16.04 using its source
>> code. When I do ./configure ./configure --with-apr=/usr/lib/apache2
>> --with-apr-util=/usr/lib/apache2 , I get the following error:
>> configure: Configuring Subversion 1.9.7
>> configure: creating config.nice
>> checking for gcc... gcc
>> checking whether the C compiler works... yes
>> checking for C compiler default output file name... a.out
>> checking for suffix of executables...
>> checking whether we are cross compiling... no
>> checking for suffix of object files... o
>> checking whether we are using the GNU C compiler... yes
>> checking whether gcc accepts -g... yes
>> checking for gcc option to accept ISO C89... none needed
>> checking if gcc accepts -std=c90... yes
>> checking if gcc accepts -w... yes
>> checking if gcc accepts -Werror=unknown-warning-option... no
>> checking for g++... g++
>> checking whether we are using the GNU C++ compiler... yes
>> checking whether g++ accepts -g... yes
>> checking if g++ accepts -std=c++98... yes
>> checking if g++ accepts -w... yes
>> checking if g++ accepts -Werror=unknown-warning-option... no
>> checking how to run the C preprocessor... gcc -E
>> checking for a sed that does not truncate output... /bin/sed
>> checking build system type... x86_64-unknown-linux-gnu
>> checking host system type... x86_64-unknown-linux-gnu
>> checking target system type... x86_64-unknown-linux-gnu
>> checking for grep that handles long lines and -e... /bin/grep
>> checking for egrep... /bin/grep -E
>> checking whether ln -s works... yes
>> checking for a BSD-compatible install... /usr/bin/install -c
>> configure: Apache Portable Runtime (APR) library configuration
>> checking for APR... configure: error: the --with-apr parameter is
>> incorrect. It must specify an install prefix, a build directory, or an
>> apr-config file.
>> I'am pretty sure those provided locations are right because I used the
>> find / -name "apache2" command to obtain them. Please tell me what is wrong.
>> Kind Regards,
> Did you look for "apr-config" or just "apache2"?  See
> https://unix.stackexchange.com/questions/41910/how-to-make-
> apr-available-for-subversion-install
> and of course the reference
> https://svn.apache.org/repos/asf/subversion/trunk/INSTALL
> You can specify the location of the "apr-config" file directly and it
> should proceed from there.
> Disclaimer:  I haven't tried to build Subversion in a long time, and I use
> CentOS, not Ubuntu...
> --
>     David Chapman      dcchap...@acm.org
>     Chapman Consulting -- San Jose, CA
>     EDA Software Developer, Expert Witness
>     www.chapman-consulting-sj.com
>     2018 Chair, IEEE Consultants' Network of Silicon Valley


Reply via email to