I run fedora and use firefox. I also update my system weekly using yum.

Recently I was testing something (directory linking) on my own local web using 
tomcat and one application.

I kept getting a total white screen with a particular test popup (using any of 
the 3 linking style and then even normal directories with NO linking).

I tried the same application on another server using my local browser and got 
the same result. So I tried another machine with another browser and found NO 
problems - both my server or the other one did things right. Checking my 
version of firefox against that box, I discovered I was running v-25 versus it 
had v-26. I actually was fully up to date but had not brought up the new 
version of firefox after a system update (no warning was given to do so and no 
OS update so no reboot requirement was obvious). I killed firefox and tried to 
restart, but a reboot was required (firefox said it was still running - ??? - 
and yea a "kill -9" probably would have fixed that, but reboot is what I did). 
Anyway, after rebooting, ALL WORKED again - the blank white screens are gone.

Apparently firefox was keeping something somewhere that made it fail with 
apache tomcat requests under certain conditions. The version running was 
confused as the next version was actually installed. This took me a couple days 
to find as I was not looking in the right places. I am just posting this in 
case anyone else has a similar problem.

Reply via email to