I'm currently having an issue with starting Tomcat 9.0.24 32-bit version as a 
service. After installing Tomcat9 using the windows service installer, I try to 
run Tomcat9 and get the windows service error:
"Windows could not start Tomcat9 service on Local Computer. Error 1067: The 
process terminated unexpectedly." I tried looking in the logs to see what could 
have caused the error, but no errors are logged. The only thing I could find in 
the logs is in the commons daemon log file:

[10860] Apache Commons Daemon procrun ( 32-bit) started.
[10860] Debugging 'tomcat9' service...
[10860] Starting service...

I also tried running Tomcat9 through the executable (tomcat9.exe) and get the 
error: "Apache Commons Daemon Service Runner has stopped working." I have also 
tried manually installing Tomcat9 through the 32-bit Windows zip and keep 
having the same errors as installing it through the installer. When I tried 
using the 64-bit version of Tomcat 9.0.24, it seems to work fine and I'm able 
to launch it as a service, which leads me to belive that something maybe wrong 
with the 32-bit version only. I'm using AdoptJDK 12.0.2+10 HotSpot 32-bit for 
Windows 10, as well as the 64-bit version when I tried the 64 bit version of 
Tomcat9. The last thing I tried was running Tomcat 9.0.24 32-bit through the 
command line window with the provided startup.bat file in the bin folder and I 
was able to run Tomcat9 and even reach the default web page. I'm just not able 
to run it as a windows service.

Any and all help is appreciated, thanks.

Reply via email to