Hi Mark

Thanks for responding. See answers below...
- what version of Apache Tomcat are you currently using?   7.0 on windows 2012 
server 
- where did you download this version from and was it a .zip, .exe or
  something else? From apache web site, .exe
- what version of Apache Tomcat do you want to move to? 7.0_Tomcat7_99, windows 
2012 server
- where did you download this version from and is it a .zip, .exe or
  something else? Apache web site, .exe

So apache only releases full versions not upgrades?  Does that mean if you run 
the version 7.99 it will create a new folder under Apache Software Foundation 
folder for 7.99 files? Since this would imply a change to the path for Tomcat 
would registry or other tomcat config files need to be modified for the new 
path? I assume all deployed .war files would need to be re-deployed in the new 
version also?

Thanks for any help!

Mike

-----Original Message-----
From: Mark Thomas <ma...@apache.org> 
Sent: Thursday, February 6, 2020 6:44 PM
To: users@tomcat.apache.org
Subject: EXT: Re: Question on Apache Tomcat Patches

On 06/02/2020 20:28, Walker, Mike (GE Aviation, US) wrote:
> HI All-
> 
> New to apache and apache patching.  I have a question.  When you run an 
> apache patch (not an upgrade or install), should the patch create a new 
> apache folder path, or simply modify & update the existing one?
> 
> For example, if I am updating apache tomcat 7 to 7_99, should I expect to see 
> a new folder C:\Program Files\Apache Software Foundation\Tomcat 
> 7.0_Tomcat7_99, or should I just see updates & modifications made to the 
> existing folder C:\Program Files\Apache Software Foundation\Tomcat 7.0 ?

"Apache" normally means the "Apache HTTP Server Project" or "httpd". I'm 
guessing from your second paragraph you are referring to Apache Tomcat - in 
which case you are in the right place.

The Apache Tomcat team does not distribute patches - we only distribute full 
versions. There are options for how to upgrade but none of them provided by the 
Tomcat community are automated.

To help you (or point you in the right direction for help) we need to know:

- what version of Apache Tomcat are you currently using?
- where did you download this version from and was it a .zip, .exe or
  something else?
- what version of Apache Tomcat do you want to move to?
- where did you download this version from and is it a .zip, .exe or
  something else?

Mark

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscr...@tomcat.apache.org
For additional commands, e-mail: users-h...@tomcat.apache.org

Reply via email to