I hit that also.  Turns out if I added this:


Then I got past the 403.  I think this is supposed to be fixed in the next 
release of tomcat.

Give it a shot.


-----Original Message-----
From: KC Mok <mok...@gmail.com>
Sent: Wednesday, March 11, 2020 11:36 PM
To: users@tomcat.apache.org
Subject: [External] After upgraded to Tomcat 9.0.31, ISAPI Redirector is not 
"working" when SSL enabled in IIS

Hi All,
I am using ISAPI redirector to connect IIS to Tomcat via AJP connector.

Recently I have replaced the Tomcat 9.0.22 with the new version 9.0.31.

I have set the new required attributes of the AJP connector in the new
9.0.31 version, and it is working fine when using http.
However, it returns error (403 Access is denied) when I use https to access the 

I tried with the lastest 1.2.48 version isapi_redirect.dll, still not working. 
After that, I tried to revert back to Tomcat 9.0.22, everything is working fine.

Does anyone have the same problem?
I wonder if I hit a bug in the new version...
please help...

Thanks and regards,

The information contained in this message may be privileged and/or confidential 
and protected from disclosure. If the reader of this message is not the 
intended recipient or agent responsible for delivering this message to the 
intended recipient, you are hereby notified that any dissemination, 
distribution or copying of this communication is strictly prohibited. If you 
have received this communication in error, please notify the sender immediately 
by replying to this message and deleting the material from any computer.

Reply via email to