We are trying to upgrade one of our tomcats from 7.0.77 to 8.5.51 and are
running into a bit of an issue.

First a bit of history on our current setup:

Apache Tomcat 7.0.77 on Solaris, 1 webapps warfile with CSH as
the shell.   In order to set our JAVA_OPTS and our CATALINA_OPTS we have,
in the past,  edited the bin/catalina.sh and on line 119 have put the
following: . opts.inc   This setup works perfectly and continues to do so.

*an example opts.inc file:*

> #!/bin/sh
> JAVA_OPTS="-d64 -server -Xms1g <snip>"
> CATALINA_OPTS="-Dtomcat.session=${JVMROUTE} -Dcom.sun.management.jmxremote
> <snip>"

The issue is now that we are upgrading to 8.5.51 and we need to use
setenv.sh (seemingly required - from our previous other bash env tomcat
upgrades).  We tried the old way but the logs/catalina.out shows that the
ENV params aren't being applied. This isn't a problem on our other tomcats
that are running bash because this works:

*Working on bash tomcats (tried in csh and didn't work)*

> #!/bin/sh
> JAVA_OPTS="-Dcom1 -Dcom2 -Dcom3 ... etc"
> CATALINA="-Dcom4 -Dcom5 etc"

*This works when manually applied on command line, but not in a script*
cat $TOMCAT_DIR/bin/setenv.sh
setenv FOO "-Dcom1 -Dcom2 -Dcom3 etc"

run the above as a test in that bin dir: ./setenv.sh (no errors)
env |grep FOO


*@ csh prompt*
setenv FOO "-Dcom1 -Dcom2 -Dcom3"

env |grep FOO
FOO=-Dcom1 -Dcom2 -Dcom3

I really don't know what to do at this point and would appreciate any and
all help.


All labor that uplifts humanity has dignity and importance and should be
undertaken with painstaking excellence.
- Martin Luther King, Jr.

Reply via email to