On 7/24/23 20:39, Fong Mason wrote:
Last month I setup a new Tomcat instance (10.1.9) since I want to have a try of 
Spring 6.x. Everything was working fine until I need to add a new virtual host. 
I had followed the instructions in to add a new 
Listener in server.xml. After I added a new virtual host and pressed “All” 
under persist configuration, the GUI said “OK - Configuration persisted” but 
actually the config is not persisted. I checked the log and found the following 
error: Error storing server

I tried to upgrade to 10.1.11 but the same problem exists, the same also 
happened for 9.0.78.

Then I downloaded 9.0.60 to try as I have another server running it and the 
persist function is working there. This time everything worked as expected. I 
tried to look at the source code of 9.0.60 and seems there is no 
ComibinedRealmCredentialHandler subclass in 9.0.60 but only in later versions. 
I am not sure if this is the cause of the problem though.

Any suggestion to make persist function work in host manager to work in 10.x? 
Many thanks.

Please find my environment for your reference
OS: Ubuntu Server 20.04.6 LTS
Tomcat: 9.0.78/10.1.9/10.1.11
JVM: 17.0.7 (17.0.7.+7-Ubuntu-0ubuntu120.04), this is a package provided by 

It looks like this is a problem with any use of the CombinedRealmCredentialHander: that class isn't effectively Serializable because the class is private.

Can you post the full stack trace?


To unsubscribe, e-mail:
For additional commands, e-mail:

Reply via email to