You should share the whole exception but think you dont use the db you
think. Check in jmx datasource mbeans maybe that your config is actually
used.

Le 20 sept. 2016 14:22, "mauro2java2011" <mauro2java2...@gmail.com> a
écrit :

> Hi all. I have installed derby.war into tomee/webapps.
> I have added the <load-onstarup> 0 </load-on-startup> to servlet derbynet.
> I have also added setenv.sh into catalina_base/bin.
> Into setenv.sh i have added
>  JAVA_OPTS ="$JAVA_OPTS -Dderby.system.home=/home/
> myaccount/myderbydatabases
>
> export JAVA_OPTS
>
> Next i have added to tomee/lib the jars of derby.
> Next i have created a web app jee7
> Into resources.xml i have configurated the datasource
>
> Whith url=jdbc:derby://localhost:1527/mydb;create=true
> User=app
> Password=app
>
> Into persistrnce.xml i have setted the option for create tables .
>
> When i deploy the webapp with Entities Customer and other entities i noted
> that into derby.system.home is created the dir mydb with db structure files
> into it.
> But when i try to visualise the rows of db with jsf pages i get errors for
> all entities pages.
>
> The error visualize the query  sended from jpa to derby db  named mydb but
> i
> get :
> Tabled not created.
> So i ask : what can be the problem ?
> Derby  have created the db into derby.system.home.
> But is eclipse-link that not create the tables.
> Please help me
> Mauro
>
>
>
> --
> View this message in context: http://tomee-openejb.979440.
> n4.nabble.com/tomee7-01-plume-not-create-tables-to-derby-db-tp4680167.html
> Sent from the TomEE Users mailing list archive at Nabble.com.
>

Reply via email to