It would be very nice to add a new phase for component creation, like I said, an init() or createContent(). Is there a JIRA issue for that? If yes, I will vote for it and suggest to change the name to something _not_ related to the rendre phase.
Thanks! Juan On Thu, May 14, 2009 at 3:31 PM, Daniel Stoch <[email protected]>wrote: > I think you can use hasBeenRendered() method instead of custom boolean > flag. > > -- > Daniel > > On 2009-05-14, at 20:15, Jeremy Thomerson wrote: > > You could probably do it in onBeforeRender - but you would need to >> keep a boolean flag to check if it's the first render so that you >> don't recreate them on a second render.... There was talking of >> adding an onBeforeFirstRender method, but I don't think it's happened >> yet - you could look for the method to see if I'm wrong. >> >> -- >> Jeremy Thomerson >> http://www.wickettraining.com >> > > > --------------------------------------------------------------------- > To unsubscribe, e-mail: [email protected] > For additional commands, e-mail: [email protected] > >
