Hello,

The quickstart is proving anything but. I run quickstart:

mvn archetype:create -DarchetypeGroupId=org.apache.wicket
-DarchetypeArtifactId=wicket-archetype-quickstart
-DarchetypeVersion=1.4.0 -DgroupId=nz.co.acme -DartifactId=myproject

Then generate and eclipse project:

mvn eclipse:eclipse -DdownloadSources=true

Then I import the project into eclipse, leaving copy into workspace
unchecked, and Run As Junit test on TestHomePage.java...

Markup of type 'html' for component 'nz.co.acme.HomePage' not found.
Enable debug messages for org.apache.wicket.util.resource to get a list
of all filenames tried.: [Page class = nz.co.acme.HomePage, id = 0,
version = 0] org.apache.wicket.markup.MarkupNotFoundException: Markup of
type 'html' for component 'nz.co.acme.HomePage' not found.

Eclipse is not copying the .html file alongside the .class. But the Java
| Compiler | Output Folder | Filtered Resources is only *.launch. How do
I make eclipse copy the html file next to the class?

No doubt there is a simple explanation, but I'm not seeing it. Can
anyone help me out?

Thanks

Dale


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscr...@wicket.apache.org
For additional commands, e-mail: users-h...@wicket.apache.org

Reply via email to